Back TFX on Google Cloud AI Platform Pipelines can't complete

Hi, During this assignment. two of the last task can’t complete. Here are the list…

  1. Test Completed Tasks - Deploy the pipeline package to AI Platform Pipelines
  2. Test Completed Tasks - Create kubeflow pipeline run using TFX CLI

Please help me to solve this issues. Thank you in advance

1 Like

Hi Noro! Do you see error messages in the outputs that might help diagnose these issues? If you can provide screenshots, that would be great.

If however, your lab shows the expected output and the grader is not recognizing it, it might be better to report this to Qwiklabs for internal checking. They may ask for a screenshot of the grader and the gcp output so it’s good to be ready with those.

Hope these help!

Actually Yesterday, I was able to diagnose problem and I solved it. Finally I solved all assignment and getting final completion certificate. I am really grateful to your support and time. Thank you so much

2 Likes

Hi,
I am stuck at 2nd and 3rd task completion. Got 1st and 4th hence scoring 60/100. These 2 can’t get despite everything running in kubeflow-pipelines-1:

  1. Compile the kubeflow pipeline
  2. Deploy the pipeline package to AI Platform Pipelines

What am i missing here?
Thanks

Hi Sanjoy! That is strange. Those two tasks should have passed before you can do the last one. Do you get any error messages in the notebook or in the Qwiklabs page so we can troubleshoot? Sometimes there is just a delay and you’ll get the green check mark if you press again after a minute or two. If you’re sure that you’ve followed the instructions correctly, you can ask for assistance using the Qwiklabs support channels since the problem might be on their end. You can find this on the upper right of the page:

The chat support is usually responsive. Just be prepared with screenshots since they usually ask for that. If the issue is still isn’t resolved through them, you can reply here so we can also escalate. Hope this helps!

Absolutely Chris. I am just not able to figure out what’s missing. As you can see the status right now.
I’ve connected with kwiklab. They are looking into it. Says there may be a bug in the lab and revert over mail.

1 Like

Hello Bolt, did you solve this problem? I think I was also stuck that step but finally I solved it. Maybe I can help you.

Hi Noro,
I got the pipeline running which I could see its progress at KFP UI as it runs each component one by one. I couldn’t see Tensorboard visualization of Trainer component. But apart from that everything seems to be working fine.
What am I missing here?
Regards
Sanjoy

Hello Sanjoy, I don’t know its work for you or not but I am telling you my solution which was worked for me. I did this update to the cloning notebook then it worked.

  1. I install same version that told notebook. before that I got errors.
  2. During the running of notebook I forget to update my kuberflow-pipelines-1 information.

Please update its work or not. Thank you

Which notebook kernel did you choose?
Python [conda env:root] *
or
Python3
I chose Python3. Could the error be due to this?

Also at the start of jupyterlab, it says ‘Build recommended’ like this:

First I tried Build. After sometime it said something to the effect ‘Can’t Build’.
After that I have used Cancel option.

Though unlikely, but could the problem be due to this? I am getting 1st and 4th task getting completion mark, but second and fourth don’t. This is for graded Lab 1.

Sanjoy.

You can choose Python 3 and I guess its not a problem.