C1W4 AccessDeniedException

Have being stuck here for two days. I was trying to run:
estimator.fit(
### BEGIN SOLUTION - DO NOT delete this comment for grading purposes
inputs=data_channels, # Replace None
### END SOLUTION - DO NOT delete this comment for grading purposes
wait=False
)
Then got error:
ClientError: An error occurred (AccessDeniedException) when calling the CreateTrainingJob operation: User: arn:aws:sts::602325892791:assumed-role/sagemaker-studio-vpc-firewall-us-east-1-sagemaker-execution-role/SageMaker is not authorized to perform: sagemaker:CreateTrainingJob on resource: arn:aws:sagemaker:us-east-1:602325892791:training-job/blazingtext-2023-10-15-20-05-30-670 with an explicit deny in a service control policy

2 Likes

Dear @Yiqiang_Song,

There is problem with your Access Control.
Please check following.
Policies and permissions in IAM
AWS Identity and Access

Please let me know if the problem still persists.

Thanks! But how do I check the IAM? I got this when try to access IAM:

+1 have the same problem. We don’t have access to change policies, please fix this.

1 Like

I am also getting the same error. I could not complete the lab. Kindly provide required IAM role / access / permissions

I am getting the same error. This is the second error with the lab " Train a review classifier with BERT and Amazon SageMaker".

1 Like

I am getting the same error too.

1 Like

Me too, i have the same error

1 Like

Same problem here

1 Like

I got the same error.

1 Like