C2_W4_Assignment- facing issue with the assignment grading

Hi All,

I am facing issue with the assignment grading , my output is matching with the expected output and all the test cases are passed, still grader gave me 0.

Exercise 5 - gradient_descent


Exercise 4 - back_prop

Same thing happening for Back_prop

Please help me to resolve grading issue.

image

If you get the correct answers in the notebook, but not from the grader, the theory would be that you have “hard-coded” something. There are lots of way to do that, e.g. referencing global variables directly which are passed to you as parameters.

No hard coding Paul.
I think there is some issue with the notebook.

And you’re the first one to discover it? I suppose it’s possible, but I think it’s a lower probability than that you have just made some kind of mistake. Are you sure you looked for references to global variables in your functions? E.g. cases in which you pass in a reference to some kind of dictionary, but reference it by its global name instead of through the parameter. So it happens to work in the notebook, but fails when the grader passes a different value as the parameter.

I have not taken this course, so I have no specific knowledge of this assignment. We’ll have to hope that one of the NLP mentors will also notice this thread.

Thank You Paul. I just emailed elemento.

@Elemento : Can you please help.

Hey @Sanjay.kumar1625,
Welcome, and we are glad that you could become a part of our community :partying_face:

Apologies for the delayed response. Let me take a look at the query right away, and I will revert back to you as soon as possible.

Cheers,
Elemento

@Sanjay.kumar1625 I am facing same problem, does your problem resolved?

No , it is not resolved yet.

Thanks
Sanjay Kumar

Hey @Sanjay.kumar1625,
First of all, sincere apologies for the delayed response.

I believe I asked for your notebook in this DM. However, I can’t find your notebook in this thread. If you have initiated a new DM, can you please provide me with the link to that?

I am actually in between my 2 machines, and hence, my notifications are messed up, and I am unable to track them anymore. Please provide me with the link, so that we can take this further.

And hey @Tarun_Singhal,
Welcome, and we are glad that you could become a part of this community :partying_face:

I have invited you to the above mentioned DM. Can you please navigate to that, and follow the steps posted in that, so that we can expedite this thread.

Cheers,
Elemento

I have the same problem; can I send my note book to some mentor here>

Hey @Nooshin_Pourkamali,
Welcome, and we are glad that you could become a part of our community :partying_face:

First of all, apologies for the delayed response. I went through your notebook that you shared. Looks like, you, @Tarun_Singhal and and @Sanjay.kumar1625 are facing a common issue. After your started working on the assignment, looks like the assignment and some of the test-cases have been updated. So, ultimately, the instructions included are outdated, however the test-cases are latest, and as a result, your code is failing the test-cases.

Can I please request you guys to refresh your notebook once? You can find the instructions here. Also, once you have refreshed your notebook, please confirm the following, so that we can be sure that you guys have indeed obtained the latest version of the notebook:

  • In the older version, the starting comments in the back_prop function are as follows:
### START CODE HERE (Replace instanes of 'None' with your code) ###
# Compute l1 as W2^T (Yhat - Y)
  • In the latest version, the starting comments in the back_prop function are as follows:
# Compute z1 as "W1⋅x + b1"
z1 = np.dot(W1, x) + b1
  
### START CODE HERE (Replace instanes of 'None' with your code) ###

Please let us know if this helps.

Cheers,
Elemento

Hi, I have the same issue and already checked that I have the latest version. Do you know what migth be happening?. I am getting good values here


but issues here

Hey @Isaida_Shiozawa,
I believe that the issue lies with your implementation, and not with the version of the assignment.

Cheers,
Elemento

Hi, how can I know what I need to fix?

I have sent you a DM @Isaida_Shiozawa regarding the next steps.

Cheers,
Elemento

Hi @Isaida_Shiozawa @Elemento I am facing the same problem. Was our code fixed ? How did you do it ? Please guide me

Sorry @OM_GAYDHANE, but I don’t know what I did wrong yet, please tell me in case you found a solution. Good Luck with the test! :smiley:

Facing the same issue. Did it get resolved

C2_W4_Assignment.ipynb (117.1 KB)
this is my notebook someone, pls help, Im facing issue with back propagation and gradient descent