C2_W4_Lab_1_WeatherData at colab - Not running

from tfx.utils.dsl_utils import external_input

is giving modulenotfound error at colab. Found tfx.dsl in TF documentation but no reference of tfx.utils.dsl_utils. One place found its reference is TFX custom component - ModuleNotFoundError · Issue #4592 · kubeflow/pipelines · GitHub where issue is something else.

Pls help to solve it.
Regards
Sanjoy

Further to above, ran without running the line:
from tfx.utils.dsl_utils import external_input

Ran all cells until transform where it got stuck.
Error is coming from tensorflow-addons.
NotFoundError: /usr/local/lib/python3.7/dist-packages/tensorflow_addons/custom_ops/text/_parse_time_op.so

I have installed the following at colab for this notebook:

  1. !pip install tensorflow-addons==0.13.0 (which is compatible with tf==2.4.2 as per GitHub - tensorflow/addons: Useful extra functionality for TensorFlow 2.x maintained by SIG-addons
  2. pip install apache-beam[interactive]
  3. !pip install tfx

Please advise how to run the notebook at colab since coursera notebook will not be available to build projects later on.
Regards
Sanjoy

Hi @bolt99 , I encountered the same problem:

when I ran to import the module:
from tfx.utils.dsl_utils import external_input

error occur:
ModuleNotFoundError: No module named 'tfx.utils.dsl_utils'

Have you solved this issues ?

By the way, I checked the entire code of this Lab, and did not find anywhere that used this module. It’s weird.