C2W3 - file not writing as .py

When I write the cover_constants file,
%%writefile {_cover_constants_module_file}
I receive the following output:
Writing cover_constants.py

When I write the transform file,
%%writefile {_cover_transform_module_file}
I receive the following output:
Writing {_cover_transform_module_file}
Instead of
Writing cover_transform.py

When I apply the transformation, I receive the following error:
ImportError: preprocessing_fn in /home/jovyan/work/cover_transform.py not found in import_func_from_source()

I do not see this directory nor the import_func_from_source() function in the lab, I reviewed the util file and cover_transform_module_file, there is no cover_transform.py file.

Any thoughts about why the cover_transform file is not writing as cover_transform.py?

Thanks in advance

I just reran the %%writefile {_cover_transform_module_file}

  • with no changes to this block -

and it now provides Writing cover_transform.py as expected.

It fixed itself.

1 Like

Ok @tbucci1

so we can mark this as solved, right?

@luigisaetta This resolved itself. I think that means, it could happen again or perhaps it happens to another individual, unless of course there was something else known happening on the app side at the time that would have caused it…

I know, I was considering, what is the most appropriate way to mark something that is no longer urgent from the user point of view, but that might be important for trend identification and troubleshooting for issues that arise from time to time. I’m assuming there is some sort of incident management in place.

So perhaps there is a closed (not solved) status. I’m not familiar with this forum.