C3 W1 - Completion of Tuning Job Grading Problem

Hi all,

I’m having trouble grading C3 W1 assignment. Everything else is being correctly graded except “Completion of Tuning Job” which has 0/15, even though the tuning job succeeded. I suppose the grading problem is related to the fact that I had some tuning jobs failing before the final one succeeded.

image


Any ideas on how to solve this?

Thanks

The way I think the grader works is by independently checking each graded part of the code. So have you ruled out that the code for that section is correct and as expected (try a few different ways of writing the vode solution)?

That’s the thing, there are only 7 code cells to complete. The grading related to the “Completions” (Completion of Tuning Job and Completion of Processing Jobs) has to be graded based on something else than code.

Maybe @esanina could be helpful to you but I would screen that part of the code thoroughly if I were you.

@hazhor could you please send me your notebook via the email elena.sanina@deeplearning.ai, I’ll have a look. Thank you!

@hazhor
Thank you for the notebook.

I ran the whole notebook in a fresh environment and it got graded with a 100% score, so I could not reproduce the problem which you have got. I would suggest starting the lab again, running the notebook again, and making the submission. Hopefully, it will work…

Please let me know if you still have any issues.

Kind regards,

Elena

Thanks, @esanina for the help. Unfortunately, I’ve tried twice to re-run the notebook with new labs and the problem persists. I really think it is something around my AWS account context. Is there any way to re-run the lab using a completely fresh account (with no past tuning jobs)?

@hazhor I have refreshed the lab account for you now, could you please try again and let me know? Thank you!

This time It worked @esanina. It was indeed something with my lab account context that was messing up the grading. Thanks :slight_smile:

@hazhor that’s great. Happy Learning!

At this step I get the following message

ResourceLimitExceeded: An error occurred (ResourceLimitExceeded) when calling the CreateHyperParameterTuningJob operation: The account-level service limit ‘ml.c5.9xlarge for training job usage’ is 2 Instances, with current utilization of 2 Instances and a request delta of 2 Instances. Please use AWS Service Quotas to request an increase for this quota. If AWS Service Quotas is not available, contact AWS support to request an increase for this quota.

How can I proceed?

@JoelsonBP could you please send me your notebook to the email elena.sanina@deeplearning.ai? Thank you!

I ran the notebook again and worked fine. Thank you!

@JoelsonBP That’s good. Happy Learning!

@esanina I am also having this same issue, where the “Completion of Tuning Job” is graded at 0/15 even though the whole notebook runs successfully. How should I proceed? Should I email you my notebook?

@karthikv thank you for the message. I would suggest to download the notebook, wait till the lab expires, start the lab in some hours (it might take a bit longer to load), upload, run and submit the notebook. Please email me the notebook if that won’t help (elena.sanina@deeplearning.ai).

I am also having this same issue, where the “Completion of Tuning Job” is graded at 0/15 even though the whole notebook runs successfully. How should I proceed? Should I email you my notebook? And I also did “download the notebook, wait till the lab expires, start the lab in some hours (it might take a bit longer to load), upload, run and submit the notebook”. That didn’t help

@plane28 thank you for the message. Could you please email me your notebook.

hi @esanina , I started the lab again, uploaded my notebook, and ran it from start to finish, and still received the same 85/100 grading issue. I just emailed you my notebook!

Did you find what is the problem?