C3 W1 Ex 3 error

when running this cell:
tuner.fit(
### BEGIN SOLUTION - DO NOT delete this comment for grading purposes
inputs=data_channels, # Replace None
### END SOLUTION - DO NOT delete this comment for grading purposes
include_cls_metadata=False,
wait=False
)

I get this error:

‘super’ object has no attribute ‘_prepare_for_training’

Hi @Pejhan,

Your answer is in the right track in exercise 3. Can you please share your screen to Ex1?

Cheers!

thanks @Rahul

here is the EX1

from sagemaker.inputs import TrainingInput

data_channels = {
### BEGIN SOLUTION - DO NOT delete this comment for grading purposes
‘train’: TrainingInput(s3_data=processed_train_data_s3_uri), # Replace None
‘validation’: TrainingInput(s3_data=processed_validation_data_s3_uri) # Replace None
### END SOLUTION - DO NOT delete this comment for grading purposes
}

@Pejhan: your Ex1 is also in the right track.

Maybe the setting up of your Hyperparameter Tuner in Ex2: can you please also share? :slight_smile:

:thanks:

@Rahul the problem with my Hyperpapameter Tuner… it is working now… thanks for your help

1 Like