C3W1 google console login issue

T​ried to sign in with temp credentials provided by qwiklabs by failed.

The error message is like this:

Couldn’t sign you in

student-xx-xxxxxxx@qwiklabs.net Google couldn’t verify this account belongs to you.Try again later or use Account Recovery for help.

I do use the credentials from the Connection Details panel.

Account recovery form is the only one option provided by Google to recover your account. If you want to recover your account, you will have to use account recovery form.

Before submitting account recovery form, make sure to take note of the recommended steps you need to follow when submitting account recovery form:

Hi! Welcome to Discourse! Have you tried relaunching the tool from the classroom, clicking Start Lab, and using the credentials given? It’s possible that it might have changed from the first time you launched it. Hope it works now!

hi chris, thanks for your help.
I have tried relaunch lab several times with refreshed credentials. I kept getting same error message.

Can you tell me which specific lab this is? Thanks!

Oh disregard my previous message. I see the lab in the title. Will check and update you asap

Hi! Unfortunately, I cannot reproduce this error. I was able to get inside the Console instantly using the username and password given. I think this is better settled with Qwiklabs support so they can look at your account specifically. Please access it through the link at the upper right corner:

Their Chat Support is usually quick to respond. Hope this helps!

hi there, now it says “Sorry, your quota has been exceeded for this lab” due to I have tried too many times to restart the lab.

Hi Chris, I have reached out to the qwiklabs help center and the problem has been solved. Thans a lot for your help and have a nice day.

Hi,

I tried to complete the Course 3 week 1 assignment. I posted what I see as a screenshot here. [


](https://C3W1 assignment screen)

However, I do not see any student ID or credentials to login to this link Sign in | Qwiklabs

Could anyone help me with this?

Thanks,
Kiana

Hi Kiana! Please click on the checkbox under the Coursera Honor Code then click Open Tool. That should redirect you to Qwiklabs with the instructions to get your credentials. Hope this helps!

I encountered the same issue, when I used the provided username and the password to open up the google console, I kept receiving the message " Google couldnt verify this account belongs to you". I also tried to use the chrome incognito mode but still couldnt solve this problem. Is there any other options to try to solve this problem?
Thanks in advance!

Hi and welcome to Discourse! Sorry to hear about your trouble logging in. I think this is something you can report to Qwiklabs so they can verify your account. You can find the support channels on the upper right of the Qwiklabs page.

Their chat support is usually pretty responsive. Hope they’re able to help resolve this. Let us know how it goes. Thank you!