C3W1: train and validation data incorrect

after I submitted the assignment for grading… it failed the first test… claiming the training and validation data are wrong… As the grader DOES NOT go by exercises… I can’t even tell which one is the one causing the issue!

I can only assume it’s exercise 1… I’ve used processed_training_data_s3_uri and processed_validation_data_s3_uri for the values in the dict keys for training and validation… the dict itself is used as the inputs for exercise 3. can someone please advice me what is wrong?? I’m really confused…

I guess you might have issue in the same place I had… please read thoroughly

Instructions: Pass the S3 input paths for training and validation data into the TrainingInput function

TrainingInput(s3_data=...)

Came to say that I worked on this as well with 85/100 for C3W1 and wasn’t able to understand why this mattered while rest of the lab worked. Why does the autograder require this when passing in the s3 uri directly also works?

I’ve just experienced the same issue. Exercise 1 refers to “TrainingInput(s3_data=…)” but I don’t see that function anywhere in the notebook.

This is what I have:
{
from sagemaker.inputs import TrainingInput

data_channels = {
### BEGIN SOLUTION - DO NOT delete this comment for grading purposes
‘train’: processed_train_data_s3_uri, # Replace None
‘validation’: processed_validation_data_s3_uri # Replace None
### END SOLUTION - DO NOT delete this comment for grading purposes
}

I think there’s some code missing.

Please help.

R


egards,
Chris