Anyone knows why the !wget is not working?

  1. not installed
  2. not in PATH
  3. insufficient permissions

Thank you! I run all the previous code but it still does not work for me.

I’m confused. Does the previous code use wget ? If not, then I’m not sure this assertion is dispositive.

What platform are you on, and what shell? Did you confirm wget is present and available and if you run it outside the exercise notebook it works?

Some diagnosis on your environment would be helpful. See for example

zsh: command not found: wget · Issue #7085 · ohmyzsh/ohmyzsh · GitHub

I figured it out. I have to open with the google colaboratory. Thank you so much!


You don’t have to run the labs on Google. If your shell doesn’t natively support wget you can use something that is supported, such as curl or install wget yourself from Wget - GNU Project - Free Software Foundation

However, much of the NLP course depends on trax, which to the best of my knowledge is only supported on Linux. If your don’t have wget, you’re probably not on Linux, and so Colab might be your best option. Cheers