C4W2 Graded Lab Error

Hi,

I am having issues completing the Graded Quiklab. I cannot create the clusters, see the issue below;

I can create clusters both through the Kubernetes GUI on GCP and also can if i remove the optional parameters in the command however this is not recognised by the lab marker so I cant do that.

I have contacted quicklabs and they have been no help, they only told me that they could run it fine. I have run it in incognito, cleared my cache, installed chrome fresh, ran that in incognito as well - nothing gets it to work.

Please tell me someone has a fix for this?? Bit irritating to be paying for a lab I cant do to complete the course.

Thanks

Hello. I have exactly the same issue, as I pointed out here: C4W2 graded external tool: can't create cluster

What a shame, isn’t it?

UPDATE:

Of course after I decide to post I get it to work! I removed the ‘–enable-autoscaling’ parameter and was able to pass the first progress check. I am not sure how this check validates the cluster but this manages to work.

However, this gave me faults when I came to actually deploying and requesting inference so you aren’t really able to complete the lab. However, it allows you to complete enough to get 90%. It’s a shame that you have to do this but hey, you can still read the docs.

You are able to enable auto scaling after you’ve created t cluster through the Kubernetes Engine Dashboard however this didn’t work for me. I am going to try it once more today to see if I can finish it.

2 Likes

Hi @celsofaf, have a look at my comment I just posted below. I managed to fix it (kinda).

1 Like

Glad it worked for you. However, you had to break some intended rules and ended up not getting the full marks for the activity. This activity is flawed, anyway, and it is a shame that it is so, for the money the course costs and the time we spend trying to troubleshoot something that should have come ready for us.

2 Likes

I can complete the lab based on @CooperWhite 's advice, removing --enable-autoscaling, setting --num-nodes to three, and enabling autoscaling manually.

Here are the commands I used to create the autoscaling cluster:

gcloud beta container clusters create $CLUSTER_NAME \
    --cluster-version=latest \
    --machine-type=n1-standard-4 \
    --num-nodes=3

gcloud container clusters update $CLUSTER_NAME \
	--enable-autoscaling \
	--min-nodes=1 \
	--max-nodes=3
2 Likes

Hi everyone! Thank you for catching this and also troubleshooting! This might be due to a recent update to the Google Cloud API. This lab was working before. I also retried the lab and indeed Cooper and James’ solutions worked. I just modified the command a bit to not use the beta anymore:

gcloud container clusters create $CLUSTER_NAME \
    --cluster-version=latest \
    --machine-type=n1-standard-4 \
    --num-nodes=3

gcloud container clusters update $CLUSTER_NAME \
	--enable-autoscaling \
	--min-nodes=1 \
	--max-nodes=3

The lab was able to get through all grading checkpoints. It might also be safer to use the stable cluster version instead of latest but let’s see what the Qwiklabs team recommends. Will escalate this issue now to our partners so the instructions can be modified accordingly in the lab itself. Thank you!

What is everyone using as their username and password for qwiklabs? I clicked on “open tool” and it takes me to a login page. Do I have to create a new user and pw for qwiklabs?

Great to hear that we are able to get it to work now - I will redo the lab to completion.

Thanks for escalating this for us.

1 Like

Hi mate,

When you have to log in you can use the credentials that are contained in the info box in the quiklab documentation.

When you press the “Open Google Console” you will have a google log in screen, I am already logged in so mine looks like this:

I press “Use another account” and copy the “Username” text from the first image:

Then I use the password from the same box to log in.

You will have a “Welcome to your new account” box. Just press accept and you will be in the GCP.

You can see this procedure in the first part of the assessment documentation:

image

Hope this helps