C4W2 Lab running curl command

Hello,
I wonder about how to send the POST request using curl. I mean this command:
curl -X POST http://localhost:81/predict
-d @./wine-examples/batch_1.json
-H “Content-Type: application/json”

where it is expected to run. As I see in the screenshot below, I see that I can enter directly the batches, but if I run there curl I got an error.
Thanks in advance.

Did you get a response to this? I am having the same issue. I have the server running on port 81, and have executed the command in the command line, in the appropriate directory. As expected when transferring data in the .json file to the server, I am getting a host of field required messages back in the output.
It is almost like there is a disconnect between transferring data to the model, and the model not existing.
As I am starting to debug from scratch, I am keen to see the response you have.

Hello @mmason, welcome to Discourse.
I did come back and tried again in a new WSL window in the no-batch directory, and it worked well. See the screenshots below.
The first one is for the no-batch situation, where it replied just one prediction value. The second is the batch situation, where it delivered a list of predictions.
One small detail that stopped me the first time was a “dot” at the end of the instruction to building the docker image.
Best