C4W2 - Qwiklabs - HPA replicas

Hello,
I did manage to get until the Monitoring the load test section. I got 90%. The script did start running. However, I am not sure if the script worked properly. Finally, the situation stayed with only one pod, and the script stopped sending requests.

So I wonder what could have happened if I got all the previous steps correctly evaluated. In any case, I did find a message in the terminal about an invalid url, and failed to parse. However, I was not sure how to fix that. See some screenshots below. Thanks in advance for your comments/help.







Hi Sergio! From your screenshots, it seems you included the brackets in the IP address when creating the URL. It should look something like http://1.2.3.4:8501 instead of http://[1.2.3.4]:8501.

Before installing locust, make sure that you are getting some predictions when you send the command:

EXTERNAL_IP=[YOUR_SERVICE_IP]
curl -d @locust/request-body.json -X POST http://${EXTERNAL_IP}:8501/v1/models/image_classifier:predict

If you’re getting a reply there correctly, then the next section with HPA should also work. While sending the multiple requests with Locust, I found that you need to click the Refresh button from the dashboard once in a while (after around 2 to 3 minutes) so you can see if new pods have been activated. You will see your deployment scale up and scale down depending on when you refresh.

Hope this helps!

1 Like

Hi Chris,
Thanks for your reply.
Yes, I did get the predictions ok.
I did check and it worked well. I got 100 points.
Thanks again, much appreciated your support.
Best
Sergio