C4W3 - CI/CD pipelines with GitHub Actions

The test is meant to be passed, but my code does not pass the test (did not change anything)

Problem is: “Version 3.7.7 with arch x64 not found”, but it seems to be there:

What to do?

Could you please try again? I’m able to pass the test upon a dummy commit. If the test fails, please share the expanded feedback like I did. Do specify the steps you performed as well.

Expanded feedback:

Steps performed:

Sorry. I’m unable to reproduce this issue on linux and so have asked a mentor / staff to help you out.

1 Like

Thank you @balaji.ambresh

I am having the same problem, running on a MacBook Air.
I am attaching the error screenshot and a screenshot from a link in the error screen showing the versions of python 3.7.7 that are available.
Any help is appreciated.
Thanks,
Pat


I did see that the file showing the versions has:
{
“filename”: “python-3.7.7-linux-20.04-x64.tar.gz”,
“arch”: “x64”,
“platform”: “linux”,
“platform_version”: “20.04”,
“download_url”: “https://github.com/actions/python-versions/releases/download/3.7.7-96789/python-3.7.7-linux-20.04-x64.tar.gz
},
But in the ‘Setup’ area it says:
Runner Image
Image: ubuntu-22.04
Version: 20221119.2

So is it that my setup is looking for ubuntu 22.04 but my system only has 20.04?
If so, what can I do about this?
thanks
Pat

Solved the problem by editing the workflow file (.github/workflows/course4-week3-lab.yml), changing the python version from 3.7.7 to 3.11.0. I chose 3.11.0 because that was one of the versions from the “list of all available versions” where the OS version 20.04 was included. The OS version was specified in the beginning of the .yml file.

To make the Action run, I then changed a comment in main.py and did a push.

So now it works and the test passes! :slight_smile:
Pat

Thanks for sharing the solution, Pat. As you can see here, I was able to run the lab without changing the python version. I’ve asked the staff to provide clarification on this one.

Same here. I got this error when running as is

Run actions/setup-python@v2
Version 3.7.7 was not found in the local cache
Error: Version 3.7.7 with arch x64 not found
The list of all available versions can be found here: https://raw.githubusercontent.com/actions/python-versions/main/versions-manifest.json

Updating the python version in course4-week3-lab.yml to 3.11.1 resolved the issue for me.

I will try to reproduce this error and if I’m not able to reproduce/figure out what is going on I will simply change the Python version to 3.11 for all learners. Thanks for flagging this!