C4W3 - task2 anthos installation

getting this error in task 2 while installing anthos
[ERROR]: Autopilot clusters are only supported with managed control plane.
can anyone please suggest something

2 Likes

Did you contact qwiklabs help?

hello,
I’m with the same error.
I change num-nodes (6 to 4) for create the cluster

not yet, can you tell how to contact them

There is a ? (i.e. question) link on top right of the qwiklabs assignment page. Click that and then pick chat / email help.

the chat help is not working, do you have some workaround for this which can work, I am struck at this point only.

Please watch this topic

Same problem but no solution. I have reported the issue.

@Felipe_Operti
Please comment on the other topic.

Hi all. I tried the lab again and filed a ticket with qwiklabs and another one with the staff as well. Thanks.

@balaji.ambresh
Did they say when this issue will be solved? This is my last assignment to complete the course and would be frustrating to pay another month just to finish this lab.

Sorry to hear that.

Qwiklabs help said that they’ll get back within a couple of hours.

Hi everyone! Thank you for reporting. We are looking into this issue and will update this thread asap. Thank you!

Hi everyone! I was able to get past Task 2 and install ASM in Task 3 by using an older version of GKE. Please run this instead:

gcloud config set compute/zone ${CLUSTER_ZONE}
gcloud beta container clusters create ${CLUSTER_NAME} \
    --machine-type=n1-standard-4 \
    --num-nodes=6 \
    --workload-pool=${WORKLOAD_POOL} \
    --logging=SYSTEM,WORKLOAD \
    --monitoring=SYSTEM \
    --subnetwork=default \
    --cluster-version=1.21 \
    --labels mesh_id=${MESH_ID}

Sorry for the inconvenience and I’m filing a report now to our partners. That bug is very recent and didn’t come up in my last testing with 1.24. I hope the workaround above also works for you!

1 Like