C4W3: TFX on Google Cloud Vertex Pipelines

The generated definition file looks fine but when it is submitted using kfp client with:

# docs_infra: no_execute
from google.cloud import aiplatform
from google.cloud.aiplatform import pipeline_jobs

aiplatform.init(project=GOOGLE_CLOUD_PROJECT, location=GOOGLE_CLOUD_REGION)

job = pipeline_jobs.PipelineJob(template_path=PIPELINE_DEFINITION_FILE,
                                display_name=PIPELINE_NAME)

job.run(sync=False)

It returns immediately but absolutely nothing happens. I see nothing under Vertex AI > pipelines (except “You don’t have any pipeline runs in this region yet”). I thought I could maybe create a manual run but clicking on “CREATE RUN” opens an empty popup.

I tried adding a print(job) before (and also after) running the job but all I get is an exception which in the end says “RuntimeError: PipelineJob resource has not been created.”.

I also tried restarting everything from scratch but with the same result.

1 Like

Actually I had 4 successful run. I just didn’t think of switching to the right region…

6 Likes

benohead - thanks for saying how you solved this. I had the same problem and had not thought to check on this. Fixed it for me as well. :slight_smile:
Pat

1 Like

Thank you for sharing how you solved this :grinning: A big help!