C4W4 - Face Recognition

Hello! I’ve seen multiple people report the same error so now I understand I’ve got a problem with the output of Exercise 1, it needs to be a scalar value and I’m outputting a Tensor. I cannot find a way to solve this, and also, I don’t seem to be getting the “All tests Passed” nor do I get an Error. It justs outputs my Tensor with the correct value…

Can anyone help me with this?

Thank you!

Guillem

Hey, don’t worry about it, you’re just supposed to get the correct tensor (the same as the one mentioned in the Expected Output) there. The Asserts there would tell you if you have the wrong value.

Thanks for your reply! The problem is that when I submit the assignment, I get an error:

[ValidateApp | INFO] Validating '/home/jovyan/work/submitted/courseraLearner/W4A1/Face_Recognition.ipynb'
[ValidateApp | INFO] Executing notebook with kernel: python3
2021-05-24 06:20:22.333269: W tensorflow/stream_executor/platform/default/dso_loader.cc:59] Could not load dynamic library 'libcudart.so.10.1'; dlerror: libcudart.so.10.1: cannot open shared object file: No such file or directory
2021-05-24 06:20:22.333309: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
2021-05-24 06:20:23.886855: W tensorflow/stream_executor/platform/default/dso_loader.cc:59] Could not load dynamic library 'libcuda.so.1'; dlerror: libcuda.so.1: cannot open shared object file: No such file or directory
2021-05-24 06:20:23.886891: W tensorflow/stream_executor/cuda/cuda_driver.cc:312] failed call to cuInit: UNKNOWN ERROR (303)
2021-05-24 06:20:23.886913: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:156] kernel driver does not appear to be running on this host (ip-10-3-0-29.ec2.internal): /proc/driver/nvidia/version does not exist
2021-05-24 06:20:23.887089: I tensorflow/core/platform/cpu_feature_guard.cc:142] This TensorFlow binary is optimized with oneAPI Deep Neural Network Library (oneDNN)to use the following CPU instructions in performance-critical operations:  AVX2 AVX512F FMA
To enable them in other operations, rebuild TensorFlow with the appropriate compiler flags.
2021-05-24 06:20:23.913533: I tensorflow/core/platform/profile_utils/cpu_utils.cc:104] CPU Frequency: 2999995000 Hz
2021-05-24 06:20:23.915173: I tensorflow/compiler/xla/service/service.cc:168] XLA service 0x55ccfe3f1be0 initialized for platform Host (this does not guarantee that XLA will be used). Devices:
2021-05-24 06:20:23.915204: I tensorflow/compiler/xla/service/service.cc:176]   StreamExecutor device (0): Host, Default Version
[ValidateApp | WARNING] For autograder tests, expecting output to indicate
        partial credit and be single value between 0.0 and max_points.
        Currently treating other output as full credit, but future releases
        may treat as error.
[ValidateApp | WARNING] For autograder tests, expecting output to indicate
        partial credit and be single value between 0.0 and max_points.
        Currently treating other output as full credit, but future releases
        may treat as error.
Tests failed on 1 cell(s)! These tests could be hidden. Please check your submission.

I thought it may be related to exercise 1, seeing as I don’t output the scalar value, but the tensor. Do you think it’s unrelated?

Thank you!

Yes, its unrelated, its probably an issue on some other cell.

Thanks! I changed a couple of lines of code in other exercises and the assignment was successfully graded!