Chroot error when trying to do “Ungraded Lab: Intro to Kubeflow Pipelines”

I am running into a chroot error while working through the “Ungraded Lab: Intro to Kubeflow Pipelines.” I am running Docker 4.4.2 (I see 4.12 is available so I’ll try that in a minute) on macOS 12.6 and am using kind 0.16.0 installed through Homebrew (it is apparently not straightforward to install an earlier version using Homebrew, e.g. v0.9 which the colab was tested on). The colab states that it does not support Kubernetes 1.22, so I’ve tried to follow the instructions twice, using these two commands to create the cluster:

  • kind create cluster --image=kindest/node:v1.21.14
  • kind create cluster --image=kindest/node:v1.19.16

I got the same error both times while attempting to run the pipeline; the download_data step fails with the error:

This step is in Error state with this message: Error (exit code 1): cannot enter chroot for container named “main”: no PID known - maybe short running container

Does anyone know how to fix this?

It appears that updating to Docker 4.12 has resolved the problem.