Dependencies issues

Hi,

I keep having dependencies issues when I install tensorflow + tfx. Could anyone with a working environment send me a txt files with the libraries version used?

The conflict is caused by:
tfx 0.23.1 depends on pyarrow<0.18 and >=0.17
tfx 0.23.0 depends on pyarrow<0.18 and >=0.17
tfx 0.22.2 depends on ml-metadata<0.23 and >=0.22.1
tfx 0.22.1 depends on ml-metadata<0.23 and >=0.22.1
tfx 0.22.0 depends on tfx-bsl<0.23 and >=0.22
tfx 0.21.5 depends on tensorflow-data-validation<0.22 and >=0.21.4
tfx 0.21.4 depends on tensorflow-data-validation<0.22 and >=0.21.4
tfx 0.21.3 depends on tensorflow-data-validation<0.22 and >=0.21.4
tfx 0.21.2 depends on tensorflow-data-validation<0.22 and >=0.21.4
tfx 0.21.1 depends on tensorflow-data-validation<0.22 and >=0.21.4
tfx 0.21.0 depends on ml-metadata<0.22 and >=0.21
tfx 0.15.0 depends on tfx-bsl<0.16 and >=0.15.3
tfx 0.14.0 depends on ml-metadata<0.15 and >=0.14
tfx 0.13.0 depends on ml-metadata<0.14 and >=0.13.2

Thanks,
Aymeric

Hi @AymericPeltier

this is from an environment I have used to test the MLEP2. It contains also additional packages you don’t need. Take care that I use anaconda.
requirements.txt.py (8.0 KB)

(remove the extension .py, I added it to be able to upload the file here)

1 Like