Error in "Feature Engineering with Accelerometer Data"

Lab “Feature Engineering with Accelerometer Data” gives the following error when installing packages.
ERROR: Could not find a version that satisfies the requirement tfx-bsl<1.5.0,>=1.4.0 (from tensorflow-transform) (from versions: 1.8.0, 1.9.0, 1.10.0, 1.10.1, 1.11.0, 1.12.0)
ERROR: No matching distribution found for tfx-bsl<1.5.0,>=1.4.0

I would appreciate it if you correct the notebook in order to complete the lab.
Thank you

Thanks for bringing this up. The staff have been notified about this.

Replace,
!pip install tensorflow_transform==1.4.0
!pip install apache-beam==2.39.0
with,
!pip install tensorflow_transform
!pip install apache-beam

and the notebook works without any error.

1 Like

Hi everyone! The labs are now updated to use more recent packages, similar to Ameer’s note above. You can now retake them. Thank you!

1 Like