glue:GetDatabase action

Hi guys

I am Jamal

when I am running the assignment of week 1, in get the following error in Exc 2:

“no permissions boundary allows the glue:GetDatabase action”

I changed the roles and policies but I get the same error again.

Hmmm… You shouldn’t ever need to fiddle with the roles.
Just to double check, you are using incognito to access it right?

If it’s still not working you can send me your notebook and I can double check everything is hunky-dory there.

Thank you for your reply.

this is my file you can find it


in the attachment.

I solved that problem by modifying the policies, but I got another error in Athena.
I don’t know why this exercise needs policy modification.

Thank you in advance

C1_W1_Assignment.ipynb (86.6 KB)

Sorry for the delay, I believe I found the source of the error: the SQL query you used is incorrect. You were really close though, take another look at the hint that is there and you should be able to get it. If not, come back and I can lead you in the right direction.

Hi Graham

I corrected the Query but the error is the same. I think the problem is due to my account. the problem is in code. the additional problem is that my account reached to limited free access and I cannot continue my assignment. could I open the new one with another email and start every thing again?

Could you explain the limited free access issue a bit more? We have a 20$ daily limit I believe, so you should be able to continue it by the next day.

I tried and everything is the same.
Could I send the information about my account and you log in to evaluate the situation?

I also tried to open a new account with a new email but it seems it requires a credit cart. In the event that last time it was not required.

Oooo I think I know what’s happening. You are talking about opening a new account on AWS and not on coursera correct?

That would make sense as your account on AWS would not have the permissions to access the database.

The way you go about accessing AWS is by using the incognito browser. The way I do it is using the normal browser to navigate around first as usual, then when you need to do a lab, second click the link on the left side panel and click open in incognito and use that window to open the Vocareum → AWS.

Thank you so much, Graham. But the assignment’s problem is still the same and I have to make a strategy to solve it.

Bests,