Grader Error: Grader feedback not found in C3W1

Hello @Mubsi,

Thanks for taking a look.

Yes, I tried submitting it just now, and the grader failed it. All exercises show the grader output as : “Grader found global variables inside graded fuctions. Please avoid using global variables in your functions.”

I have checked several times and have not used global variables in any of the functions.

Kindly help so that I can move forward.

Thanks,
Shanup

Hi @shanup,

In Ex 6, you were passing the model variable as a global variable, rather than using the one provided in the parameters of the function. Check it now.

Cheers,
Mubsi

Much appreciated @Mubsi.

From my side, I did spend a lot of time trying to identify where I was using a Global variable, but since the Grader marked all the exercises as violating this rule, it was like looking for a needle in a haystack.

If the Grader had been a little more specific about which exercise was violating the rule, it would have greatly helped.

Thank you very much for your help, Sir.

Best,
Shanup

Hi @shanup,

Yes, that is an issue which people have raised a lot of the times. We’ll see what we can do about it.

Best of luck with the rest!
Mubsi

Hi @Mubsi
I have the same issue with C4_W3. I checked several times but I still get grader not found error.
I would appreciate if you help me with this.

Lab id : trevogss

Thanks,
Narges

Hey @Mubsi ,

I am running into the same issue could your please help me with this too?
its on C3W4
Lab id : uccieckg

Best
Jordan

Hi @mubsi,

Lab id: ivvddrqm

My C3W1 is failing as well, and I cannot spot use of a global variable anywhere. In fact if you look at the /notebooks/C3_W1_Assignment-Copy.ipynb notebook, I tried the following experiment. I moved all the global code that is not inside a function to a function called foo() (yeah, lame!). That way, the other functions are not privy to anything inside foo(). Now, they only way for the other functions to work is through parameters that are explicitly passed in. All the tests pass.

I’m at a complete loss. If it is possible to help, I’d much appreciate. I got a pass grade (70/80) here, but it bugs the hell out of me.

@Mubsi
Hi Sir, I’ve stuck in this problem. I’ve tried making fresh copies, checking the use of global variables, and deleting cookies etc. Howver, it was not solved. Could you help me?
My lab id is mseibtgf. Thank you very much!

Hi @Narges_Farokhshad, @Jordan_Browne-Moore, @Sriram_Srinivasan, @saanghyuk,

Is this something you still need help me ? Let me know.

Thanks,
Mubsi

Thank you for responding, @mubsi. Yes, I am interested in what I got wrong. But I am more interested in what I can do about it the next time I see an error like this. If it is putting an error out on stderr, I’d like to see that error.

But meanwhile, yes, if you can see what is wrong with my submission, I’d be grateful. Lab id: ivvddrqm

Thank you.

Hey @Mubsi, Yes I still need assistance with this.

Hi @Sriram_Srinivasan,

After reading your comment above and going through your notebook, I see you have added extra code within the notebook (more than what was asked). Especially creating new functions and adding print statements and new code block cells. This will disturb the grader, as it expects everything as the original notebook. Kindly remove everything extra you added. In case you don’t remember, just fetch a new copy and only copy/paste the code that’s originally required. Try it then. If the issue still remains, let me know.

@Jordan_Browne-Moore, kindly take note of the same. If you haven’t added anything extra, let me know and I shall look at your notebook. But if you have, remove everything extra and then try.

Cheers,
Mubsi

@Mubsi Unfortunately I am getting an error that presents as:

  • Grader Error: Grader feedback not found

Visit the Discussion forum to see if your peers are experiencing or have found resolutions for similar errors. If the error isn’t resolved in 24 hours, please reach out to Coursera through our Help Center.

Hi @Jordan_Browne-Moore,

Firstly, I see that your issue is related to NLP C3 W4, but this is the channel for C3 W1. Going forward, kindly make sure you post things in the appropriate channel.

As for the issue, I have DM you regarding it.

Best,
Mubsi

Hi,
@Mubsi I am facing this same issue. I have rechecked my code multiple times also tried fetching new latest copy but none of the solution worked. Please help
lab id- dbfsmtmc

for anyone making it to the bottom of this thread, look really really hard for global context variables that have sneaked into your functions. I did a cut and paste error and used

y_weights=tmp_example_weights

where I should have used

y_weights=example_weights

All unit tests passed, but the grader was really unhappy, in a totally passive aggressive kind of way. Took me hours to track it down.

Same problem…Tried many times, not sure how to fix.

Hi @Mubsi
My Lab ID is rgmwhebe
Pls resolve my issue as fast as possible because this assignment due is Today

Hi @Tushar3,

I hope you understand that you cannot ask me out of the blue to solve your assignment for you, especially when you haven’t mentioned what issue you are facing, where it is or shared any of the error output trace. I’d be looking at your assignment without knowing what I have to help you with.

With that being said, please share what issue you are facing. If it is the “Grader feedback not found” related, then I’d recommend to take a look at the note at the start of the assignment Important Note on the Autograder, and make sure you are not doing any of the listed things.

Let me know if you’d still need help after.

Best,
Mubsi

hi @Mubsi can you solve the same problem (grader feedback not found)
my lab ID is:acxndzfl