Invalid input error: C4W3_Lab_1_Kubeflow_pipelines

Hi every one is been a great learning journey for me. I have been trying to create my pipeline from uploading the yaml file. but I can’t seem to name the file I have used both alphanumeric but still it gives me the same error I don’t know what else to try


thank you guys for always helping out.

1 Like

Please click my name and message your notebook with cell outputs as an attachment.

Hi Nnaemeka. You might be using a different version of Kubeflow Pipelines. Please uninstall it first with this:

export PIPELINE_VERSION=2.0.5 // or whatever version you might have used. remove this comment to avoid error.
kubectl delete -k "github.com/kubeflow/pipelines/manifests/kustomize/env/platform-agnostic-pns?ref=$PIPELINE_VERSION"
kubectl delete -k "github.com/kubeflow/pipelines/manifests/kustomize/cluster-scoped-resources?ref=$PIPELINE_VERSION"

Then reinstall with this:

export PIPELINE_VERSION=1.8.5
kubectl apply -k "github.com/kubeflow/pipelines/manifests/kustomize/cluster-scoped-resources?ref=$PIPELINE_VERSION"
kubectl wait --for condition=established --timeout=300s crd/applications.app.k8s.io
kubectl apply -k "github.com/kubeflow/pipelines/manifests/kustomize/env/platform-agnostic-pns?ref=$PIPELINE_VERSION"

I just noticed the default command in the notebook was throwing an error. It’s now updated to match the one currently in the official docs but with a different version.

If you get the same error, please try modifying the pip install in the Colab to !pip install --upgrade kfp==1.8.5, run the notebook, download the new pipeline.yaml, and upload that. It’s supposed to be backwards compatible but I’m not sure if it works on all setups. We might as well make sure that that is not the issue.

Hope this helps!

Hello thanks for the help I tried again and it still shows me the same error when I upload the pipeline.yaml. I also tried updating to

!pip install --upgrade kfp==1.8.5 instead of 1.8.22
but it gives this error in the picture above.

Hi! But were you able to uninstall the current KFP you had, and then run this?

Also, can you post the output of this command when you run it in the terminal? kubectl version

thank you so much it worked after I change this line from this

kfp.compiler.Compiler(mode=kfp.dsl.PipelineExecutionMode.V2_COMPATIBLE).compile(
pipeline_func=my_pipeline,
package_path=‘pipeline.yaml’)

to this and downloaded the pipeline.yaml

kfp.compiler.Compiler().compile(my_pipeline, package_path=‘pipeline.yaml’)

I think its a compatibility issue with my local machine

1 Like

this was the output to delete


this was the output when I was applying the resources

this is it

but currently this is the issue I am facing. the download data pipeline is throwing an error.


I am happy I am running into all these issues it motivating though frustrating also when you have to debug for hours but there is no better way to learn faster. Thank you guys for always being here to help

Thank you for sharing the solution to the upload problem! Thanks as well for the other info. I’ll try to replicate this on a Windows machine, and get back to you.

Nonetheless, please don’t let this hinder your progress in the course. The pipeline is setup for you in GCP so you wont run into these issues. This is only meant for practice so you’ll be familiar with the basic components and the UI. The repo is publicly available so you can always go back to it even after you complete the course.

1 Like

By the way, I notice in your screenshot that the Kubeflow Pipeline version is 2.0.5 (lower left). I think the error stems from there. It should show 1.8.5 if the reinstall was successful. If you have that version, maybe you dont have to modify the command in Colab.

Please make sure you’re executing this line before you do kubectl apply during installation:

export PIPELINE_VERSION=1.8.5

It will ensure that you have the expected version for this lab.

1 Like

Please try again with these steps:

  1. export PIPELINE_VERSION=2.0.5 then delete the current installation. (it seems this did not run successfully based on your screenshot. it was trying to delete 1.8.5 that it couldn’t find)
  2. export PIPELINE_VERSION=1.8.5 then install KFP
  3. run the Colab again but revert to the original commands.
  4. launch KFP and check that the version shows 1.8.5
  5. upload the YAML file
1 Like

yeah it is version 2.0.5. thank you so much I would try it again and revert with the solution. secondly I use powershell in windows so I use the command

set PIPELINE_VERSION not export PIPELINE VERSION

the later throws an error i hope I am doing the write thing or is there a way to make my powershell use the comma EXPORT

Ah yes you should use set if that’s what works in PowerShell. Don’t worry about export. Will update the instructions so learners with the same setup will be aware. Thanks!

Thank you it has been a great journey. I just noticed that anytime I set the pipline_version=1.8.5 it still gives me the 2.0.5 version as you can see in the image


I deleted it but when i reinstall with 1.8.5 when the UI opens I still see 2.0.5 I don’t know why that is happening. By the way I am progressing in the I have done in it GCP. I just love to get solution if I ecounter an issue. I am sorry I don’t respond very fast it takes almost 2 hours at minimum for my deployments to be ready in the assignment it states around 30 minutes.

Hi. The screenshots only show deleting the old version. Please also include screenshots of the installation. You might have forgotten to set the pipeline version, hence it’s 2.0.5 that got installed.


here is a picture where I set the pipeline version

HI Nnaemeka. Sorry I don’t think this showed up in my notifications. Were you able to resolve this on your last attempt? I suspect there’s an existing installation that’s why you still saw 2.0.5.

hello it has been a while. thank you.
from my screen shot you can see i did unistall it I tried to install the version 1.8.5 but i still get version2.0.5 so I don’t know what else to do. I have finished the course and learned from the GCP setup. but i just feel like i need to be able to run it on my local machine.