Keep getting error "Check the dot product" in Neural Network assignment 1

The “my_dense” subroutine works fine because the output displayed on the screen for the test example works. Only when the code calls the .py script in UNIT TEST, it fails. We do not have access to the unit test code to check what is wrong. It says “check the dot product” , but as I mentioned this dot product is being computed correctly, as the test examples in the code are working.

Same error for my_dense_v also

Hi @priya.parandekar,

Yes - you can access that code. In the jupyter notebook, click “File” > “Open” and look for the file “public_tests.py”.

Raymond

Okay sure, will look into this.
Thank you,

i get the same error in my_dense_v and try all things but still don’t work ?

Hi @omar_khaled2, please check out the hints under the exercise cell for how to implement the dot product correctly.

Cheers.
Raymond

Actually this “dot product error” is misleading. This error is saying “check the dot product”, even though the dot product is computed correctly.