Kubeflow pipeline in C4_W3_Lab_1_Kubeflow_Pipelines does not support Kubernetes 1.22 and above

It’s worth pointing out that the Kubeflow pipelines in C4_W3_Lab_1_Kubeflow_Pipelines do not support Kubernetes version 1.22 and above. It took me a good 2 hours of figuring this out. See this SO question.

Diving into the URLs used to create the pipeline pods on the Kind cluster, it uses the ../v1beta API, which apparently has been deprecated after Kubernetes 1.22.

Can the course instructors update this so other learners don’t get unnecessarily stuck?

2 Likes

I even tried to clone pipelines locally, find/replace “v1beta” with “v1” as the changelog suggests, but had no luck still.

Hi! Thank you for reporting! We’ll place a note in the notebook accordingly. Thanks again!

Hello!

Can you help me?

I tried to do what was requested to solve this error (link). I am still getting the same error after I followed the tutorial


.

@ksilva did you find a solution? Meet the same issue.

Yes, I did. In my case, I didn’t edit the YAML file correctly. I still get the warning, but it works.