Lab3 of Course 3 problems: Submission notebook was not found in the S3 bucket

I have completed Lab 3 of Course 3, “Optimize ML Models and Deploy Human-in-the-Loop Pipelines.” I ran the code in the lab environment successfully without any errors, but the submission report shows that I failed to pass most of the exercises in Lab 3 of Course 3.

I completed Exercise 1- Exercise 10 successful in the course 3-Lab 3:

In Exercise 2, I built the Amazon Cognito user pool client successfully:

I’ve already attempted to re-run the notebook with building new labs multiple times over the past two weeks, and the problem persists. Every time I did the lab experiment on different days or in different time sessions, I got the same submission report, even though I modified my code. I suspect that the issue might be related to my AWS account context.

The second issue is after I perform exercises 1–10 successfully without errors. The code ran over 1.5 hours in “4.5. Verify that the human loops were completed by the workforce”, but was still in process. It seems like a dead loop.

In the previous tries in Lab 3 of course 3, I skipped the last cells after “4.5. Verify that the human loops were completed by the workforce” due to an issue. The code in that section (4.5. Verify that the human loops were completed by the workforce) ran for over an hour prior to being stuck in a loop.

I did Lab 3 again. I skipped the “dead loop” and executed the last cells until the end of the Jupyter Notebook. It worked successfully, earning me full marks. However, I’m still puzzled about the “dead loop.” It shows “waiting for HumanLoop to complete” repeatedly for such a long time.
image