Practical Data Science C2W3: Unable to Locate Credentials

Hi! I got credential errors for submitting the Course 2 week3 lab. The submissions of the previous two labs proceeded well. Here is the error message for lab 3:

[Executed at: Sun Dec 26 2:25:35 PST 2021]

========================================================================================================================
Test 1 failed: Please make sure that ‘### BEGIN SOLUTION’ and ‘### END SOLUTION’ comments remain unchanged for grading purposes. Please try again.
Test 2 failed: Please make sure that ‘### BEGIN SOLUTION’ and ‘### END SOLUTION’ comments remain unchanged for grading purposes. Please try again.
Test 3 failed: Please make sure that ‘### BEGIN SOLUTION’ and ‘### END SOLUTION’ comments remain unchanged for grading purposes. Please try again.
Test 4 failed: Please make sure that ‘### BEGIN SOLUTION’ and ‘### END SOLUTION’ comments remain unchanged for grading purposes. Please try again.
Test 5 failed: Please make sure that ‘### BEGIN SOLUTION’ and ‘### END SOLUTION’ comments remain unchanged for grading purposes. Please try again.
Test 6 failed: Please make sure that ‘### BEGIN SOLUTION’ and ‘### END SOLUTION’ comments remain unchanged for grading purposes. Please try again.
Test 7 failed: There is a problem with the SageMaker client. Check if the lab is started. Please try again.
Test 8 failed: Please make sure that ‘### BEGIN SOLUTION’ and ‘### END SOLUTION’ comments remain unchanged for grading purposes. Please try again.
Test 9 failed: Please make sure that ‘### BEGIN SOLUTION’ and ‘### END SOLUTION’ comments remain unchanged for grading purposes. Please try again.
Test 10 failed: There is a problem with the SageMaker client. Check if the lab is started. Please try again.
========================================================================================================================

Unable to locate credentials. You can configure credentials by running “aws configure”.

However, after I fixed the credentials in the terminal as Cloud Access AWS CLI describes in the week 3 lab tool and resubmitted the notebook. It got another error:

!aws s3 cp ./C2_W3_Assignment.ipynb s3://$bucket/C2_W3_Assignment_Learner.ipynb

upload failed: ./C2_W3_Assignment.ipynb to s3://sagemaker-us-east-1-089502606699/C2_W3_Assignment_Learner.ipynb

An error occurred (InvalidAccessKeyId) when calling the Put Object operation: The AWS Access Key Id you provided does not exist in our records.

Could you help me with this?

Best

1 Like

I am encountering a similar issue when submitting my C1W2 lab.

[Executed at: Tue Dec 28 7:00:55 PST 2021]

========================================================================================================================
Test 1 failed: Submission notebook was not found in the S3 bucket sagemaker-us-east-1-. Please try again.
Test 2 failed: Submission notebook was not found in the S3 bucket sagemaker-us-east-1-. Please try again.
Test 3 failed: There is a problem with the SageMaker client. Check if the Lab is started. Please try again.
Test 4 failed: Submission notebook was not found in the S3 bucket sagemaker-us-east-1-. Please try again.
Test 5 failed: Submission notebook was not found in the S3 bucket sagemaker-us-east-1-. Please try again.
Test 6 failed: There is a problem with the SageMaker client. Check if the lab is started. Please try again.
Test 7 failed: Submission notebook was not found in the S3 bucket sagemaker-us-east-1-. Please try again.

Unable to locate credentials. You can configure credentials by running “aws configure”.

Found a solution – I was able to fix this by doing a “Restart Kernel and Run All Cells…” in the Jupyter Run menu. After everything completed, I resubmitted and it worked.

1 Like