Programming assignment won't grade

All my of solutions match the expected solutions and its says that all tests are passed, but when I submit the assignment, Im getting 0%. The error below is as follows:

Sorry, your submission was incorrect. Please try again. Invalid control character at: line 321 column 4054643 (char 4177920)

It looks like the “metadata” in your notebook has gotten damaged or corrupted somehow. The notebooks are JSON text files that contain some information that is not visible in the UI, but which is used by the grader infrastructure. My suggestion would be to get a clean copy of the notebook by using these instructions (that is from DLS, but the notebook mechanisms are the same in all the courses). Then very carefully “copy/paste” over just your completed code from the “YOUR CODE HERE” sections from your damaged notebook to the clean copy. Then try submitting the new copy with the added code. Please let us know whether that helps or not.

Hi thank you. I followed your directions, but am receiving the same error again.

Are you sure that you submitted the clean notebook + changes, as opposed to the old one? You have to be careful with the renaming.

If so, then we need to examine the source of your notebook. Please check your DMs for a message from me.

I had exactly the same problem. Also the workbook clean copy didn’t work for me (I tried that 4 times), so I tried to rename the complete directory “W3A1” to e.g. “W3A1” - not just the workbook itself - and do all the steps you mentioned. After complete restoring I was able to successfully send it. At the same time there was a problem with Labs availability in general, so it could be a mixture of all this. Anyway, problem solved! :slight_smile:

Can you share the screenshot of grader output message which mentions why you failed the grader

you should be able to see something like this on the submission page

incase one of the cell shows incorrect, you need to go back to that cell and do the correction to pass the grader.