Solution to Error in C4_W3_Lab_1_Kubeflow_Pipelines

Hello Learners,
I was in Ungraded Lab in W3. While installing the KFP SDK, I was getting following error (look to the screenshot) . It is due to google colab default Python version of 3.10.

Error I was getting with default Python in google colab

Solution

I downgraded Python to 3.7 with following code:

apt-get install python3.7 python3.7-distutils python3-pip
!update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.7 100

Although I have installed the KFP SDK with Python 3.7. My google colab is crashed due to unknown error. Here is my logs from google colab:

Thanks for bringing this up. Given that kfp 2.0.1 supports python 3.10.12 (google colab version of python), the staff have been notified about this issue.