Tensorflow for python 2.7

For some reason, I have to use python 2.7 for my project, the tensor flow isn’t compatible with python 2.7, so is there any way to use TensorFlow for python 2.7?

I think not. 3.4 seems to be the base for TF.

Maybe the better question to ask is why you are stuck with python 2.x. That is pretty old news by this point. And if you’re new to python 2.x, there are lots of other landmines to step on. Try this:

m = 5
x = 1/m
y = 1./m

In python 3.x, x and y will have the same value 0.2. In python 2.x, x will be 0 as an integer type. It doesn’t take much imagination to see that this could cause major problems for people who are careless about the types of constant values.

We are volunteers who make and take care of the Python programming language. We have decided that January 1, 2020, was the day that we sunset Python 2. That means that we will not improve it anymore after that day, even if someone finds a security problem in it. You should upgrade to Python 3 as soon as you can.