There is no “Submit Assignment” button in my notebook

I already tried all procedures suggested by paulinpaloalto at FAQ and nothing work. This problem is occuring at week2, week3 and week4 assignments and I supose maybe it wiil happen at week5 assignments to. I’m very worried about this because if I don’t submit my assignments I will not be able to complete the Specialization.

Can you help me ?

If you have tried everything on the FAQ thread, the other possibility is that this is an IT problem either with your computer or on your LAN: some A/V or firewall or proxy may be blocking some of the accesses from the notebook. If you are working from an office or school network, you should try accessing the website from a public WiFi at a coffee shop or library or from home and see if that makes a difference. If you are already on a home network, then maybe try it from a different computer or a tablet and see if it’s the A/V software on your computer that is blocking you. It could also be that your browser either blocks plugins or you are missing some plugin. Please watch for error messages flashing by when you load the website or do some googling to find out how to check the error logs of whatever browser you are using. Or try a different browser. Ones that are known to work well with the DLAI courses are Chrome and FireFox. If none of the above helps, then another thing to try would be use a VPN if you have that available.

Of course note that it’s kind of hard for us to debug your IT problems for you. If you’re on a school or office network, you might want to try consulting with your local IT support staff (if you’re lucky enough that there is such a thing) or see if there’s a website on your LAN that talks about how to “white list” targets that may be blocked.

I agree with paulinpaloalto, if you’re having problems with multiple assignments, the cause is most likely either with your internet access permissions, or with your account setup.

  • Only you can fix your internetet access.

  • Only Coursera’s Help Center can check your account setup.

Hi Paulim, hi TMosh

Thank you for your answers and suggestions. I tried everything and nothing worked. I tend to think that the problem is really related to my account setup.

One thing that catches my attention is that the Notebooks that I had previously submitted still show the “Submit Assignment” button; to test I resubmitted some of these Notebooks and it worked perfectly.

Reading the suggestions in the Help Center there is one that says to check if your computer’s clock is set accurately. There may be something here.

For a long time now, every time I log into my Coursera account or open a Notebook the following message appears in the upper right corner saying:

" Your computer’s time zone does not appear to match the Etc/GMT+3 time zone setting of your Coursera account.
Change your Coursera time zone setting."

It turns out that the time zone is correct and I have tried several times to correct this but the message continues to appear even when I access my account from other computers.

Can you tell me who I can refer this situation to.

Thank you

Hello @Dalton_Lintz,

It might not be your case but every single time I click the following “Work in browser” button,

Screenshot_20221226_081326

then my chrome will switch to a new tab (which is normal), and the thing is, if I immediately switch to some other tab because I want to read something else instead of waiting the notebook to load up, then when I come back, the submit button won’t show up. It shows up only if I stay in the tab and wait through the loading process.

I can still reproduce this behavior with my laptop just now. I don’t know if anyone else experieneced this but want to share this with you just in case…

Raymond

1 Like

What is different about the cases that work versus the ones which don’t? Can you see any pattern? E.g. were the working ones in C1 and C2 and the non-working ones in C4 or C5? Do you have any cases in which you have working and non-working within the same course? Notice that the position of the submit button in some of the Course 4 and 5 assignments is rendered differently: instead of appearing on the “toolbar” line on the right side as in most of the earlier ones:

Instead it appears in the center of the very top of the window to the right of the Coursera logo:

Did you actually try looking at your browser error logs? Which browsers on which OS platforms have you actually tried? I guess if we really got desperate, we could try actually looking at the HTML for the website to see how the submit button is implemented. One thing to notice is that it is one of the very last things to render when you open a notebook page.

In terms of what “higher authority” to appeal to, it sounds like you’ve read the material on the Coursera Help Center, but have you actually tried chatting with them? It’s pretty hit or miss in general, but if you get lucky you might get someone who has seen this issue or could escalate to secondary or tertiary emergency care.

1 Like

Very dear Paulim,

One more time I thank you for your good-will and your interest to help me.

I read the material in the Coursera Help Center and as I guess it is possible that the problem is in my account setup and MTosh said that only them check it I think that could be useful to talk with them but not find there a place where talk with them directly.

From yesterday to today the layout of the notebooks has changed and now they are as you had said. Everything is fine now.

Thank you so much.

It’s great to hear that things work. Do you have a theory on what changed that was the key? Just for future use if other people hit this case …

Hmmm, you’re right, since the last time I visited the Coursera Help Center, they’ve made it even more difficult to find the “Contact Us” links. You have to drill all the way down to the “leaf” level on some topic and then scroll all the way down and maybe (but not always) you’ll be lucky and see the “Contact Us” link:


But even that may just be because I have the “mentor” attribute set on my account. Sigh …

Hi Paulim,

One thing I noticed on the dysfunctional notebooks was that they had a big “Proceed” button on the top right side. When pressed, the only thing it would do was “refresh” the notebook.

I would consider the following hypotheses possible:

1 - Human error (mine).
2 - Problem in my local environment (browser, internet connection, virus, etc).
3 - Problem related to my account setup.
4 - Human error (Notebooks development team).

Once the problem has self-fixed it is difficult to know what happened.

In the case of hypothesis 4, I can imagine a scenario more or less like the following:

At December 22:

  • Task to be done: : “Update the notebook’s template enabling the buttom X (“Submit”)”.

  • Task done:: "Update the notebook’s template enabling the buttom Y (“Proceed”).

At December 26:

  • Task to be done: “Fix the Notebook’s Template enabling the buttom X (“Submit”) and disabling the buttom Y (“Proceed”)”

  • Task done: “Fix the Notebook’s Template enabling the buttom X (“Submit”) and disabling the buttom Y (“Proceed”)”.

I think if any learner submitted succesfully an DLSC4W2 or DLSC4W3 in the period between december 23 and december 25 this hypotesis may be discarded.

Thank you for your help

Dalton

Hi, Dalton.

Thanks for your thorough response on this. As you say, after the fact it is pretty difficult to say for sure what happened. Of the theories, I think 4) is probably the least likely. I’m on the mailing list that gets notified when any of the notebooks are updated and I don’t remember seeing any activity in that period. It’s also a holiday week in the US, so lots of the developers were likely on break. And similarly if you didn’t actually talk to the Coursera Help Center, then they probably didn’t spontaneously change anything about your account, so theory 3 seems unlikely. Well, if you logged out and logged back in again, that might have reset some account state.

If I had to bet, I’d go with theory 2) and that something did actually get changed about your browser or other network configuration.

Anyway, we should just move on and be relieved that it’s no longer a problem.

Cheers,
Paul