Utils.exercise_x() does not work

I was work before, yesterday.
Today it stop working correctly.

FloatText(value=0.0, description='Mean:')
FloatText(value=0.0, description='Variance:')
Button(button_style='success', description='Save your answer!', style=ButtonStyle())
Output()

I think the problem because I “trust” the notebook. I don’t know how to untrust yet.

Sorry, what does “trust the notebook” mean?

I’m guessing that it is this button at the top right of the window that is meant:

Sorry, but this is most likely irrelevant. That setting only controls whether certain kinds of javascript can be executed by the notebook. You can probably turn it off by getting a clean copy of the notebook, but my prediction is that it will not make any difference.

Hmm, I never noticed that button was clickable.

Yes, I’ve never really played with it much, but you can click it and then check “Trust”. But I think it’s really irrelevant. No need for students to mess with it, but if they do it does no harm. So they could change the label to “Red Herring”. :laughing:

Can anybody please help resolve this issue? I also get this. I cannot submit any answer. It stopped working an hour ago.
If I run any utils.exercise cell, I get this below:


Please help. How do you resolve this?

I think that’s an issue with your browser blocking the dialog popups.

Try disabling any blocker plugins your have, or maybe try an anonymous/private session.

Or the old ‘clear your cache and cookies’ routine.

Thank you TMosh. In my case, empty cache and reload worked. :pray:

1 Like

Thanks for your report.