W3 Lab *Still* Very Broken

Hi,
I have been trying for a week now to get this problem resolved but have had no useful help only redirection to ask elsewhere.

To recap: W3 lab (Data labeling and human-in-the-loop pipelines…) is frequently failing to start up at all (today this remains the case). On the few occasions when I have gotten it to open, the grader is obviously failing and template code that does not even depend on user input was failing to run.

I first saw a related thread here: Unable to complete human loop task - #2 by bj.kim… explaining that the problem had been handled in another thread (here: C3W3 test 14 - taskObject - #13 by esanina). So I posted a follow up that a similar issue was occurring.
No response.

I then followed up on the original thread (Unable to complete human loop task - #3 by aamir).
No response.

I then posted again, after yet another day of trying and failing to get in.
Again… no response.

And that brings us to today, a full week later. Lab is still having issues, and I have not heard a single response attempting to help me resolve the issue.

Update: Today, after 30 mins of the lab loading, it did finally load.
SageMaker suggested that I need to reboot SageMaker… which I did, according to their instructions.

When I got in again, SageMaker again suggested I reboot SageMaker.
And although I can now see the lab again, none of the cells will actually run…

@damian thank you for the message and sorry for unpleasant experience.

We will investigate the problem and get back to you as soon as possible.

Ok… after rebooting SageMaker yet again, I am now able to run the notebook, but after having redone the assignment for the 4th time now… I am back to my original problem:


…in exercise 10 the predictor is not working. Workforce was successfully created.
The predictor itself and the reviews do not rely on any user-input code.

…and if I go ahead and submit what I’ve got, still many apparent problems with the grader.

Really? Ex. 1 is wrong? What else could it be?


…0/5

Ex 3:


…0/5

etc.

Thank you again for the screenshots @damian We apologise again for this experience.
Could you please send me the item link and AWS account number (see the printscreens below) and also download your notebook and send it to my email elena.sanina@deeplearning.ai


Thank you!

Thank you, @esanina … after waiting the 30 minutes to get the lab to spin up again, I have obtained and emailed you the requested data.
Much appreciated.

Hello @damian ,

Thanks again for all of the information. Our technical team is looking at the lab access issue that you have faced, but they haven’t got back to me yet.

I tried to submit your notebook and got a full score except for Exercise 9. Maybe the final version of the notebook wasn’t uploaded into the S3 bucket? Please try to save the notebook, run the last cell of it, get back to the lab and submit. Let me know please if that will work.

And in the Exercise 9 you need to add brackets: JSONLinesSerializer → JSONLinesSerializer() and JSONLinesDeserializer → JSONLinesDeserializer()

Kind regards,
Elena

Hi damian,
It must be frustrating!
I did have the grader issue myself, but was able to get 70% and I passed.
I would personally try the following, while the team works on the issue.

  1. Try opening the course in an in-cognito tab in chrome.
  2. Make a separate coursera account, and complete the assignments from there.

Let me know if it helps.

After about another half dozen failed attempts to get the lab to start, I did finally get on in Incognito mode, and that worked for me.
Thank you both for your help. Glad to have this finally resolved.