What to Do After Lab Expiration

Hi,

The instructions around what to do when you run out of time in a lab remain unhelpful, especially given how little control we as users of Vocareum labs have to manage the account’s lifecycle, which is not at all transparent. After the lab I started this morning died, I hit “Start Lab”. After about 20 minutes (countdown clock at 3:40), I hit the AWS button and get taken to the test account console. When I tried to open the SageMaker studio, I get this error:

“SageMaker is unable to assume your associated ExecutionRole.”

Is there a way for me to early terminate the lab, so I may start over ASAP?

Is there a way to hard kill a lab account and force a clean build? I have been getting the “SageMaker is unable to assume your associated ExecutionRole" error every time I tried to open the SageMaker studio. The lab should not be this difficult on new learners.

Happened to me as well. Here’s what I did:

  1. I closed the expired Sagemaker Studio window
  2. I clicked on the “Start Lab” button and waited till the AWS light went green
  3. I clicked the AWS (top left) which opened a new window with AWS console with an error message - I CLICKED THE “LOG OUT” button (as per the instructions)
  4. I clicked the AWS button again, this time the AWS console started properly

That said, I had some problems with the notebook in places where all worked OK before. Namely, the buckets were not created and i had to create them manually via S3 UI.