I’m trying to run again some exercesis from the ChatGPT Prompt Engineering for Developers course but I got this error:

AuthenticationError: Your authentication token is not from a valid issuer.

I deleted the cookies from 7 days ago, and I got the same result.


same here…I was trying to complete the course today and ran into the same problem. Even previous modules (which I had completed before) I am unable to run. WHat happened?

Hi and thank you for reporting! We’ve escalated the issue to our team. Will keep you posted.

Hi everyone! The bug should now be fixed. Kindly try the lab again. Thank you!

it worked! Thank you and the DLAI team!

1 Like

This happened to e today in the middle of the l2-guidelines notebook.

AuthenticationError: Your authentication token is not from a valid issuer.

on this line:

Cell In[11], line 18
      1 text = f"""
      2 You should express what you want a model to do by \ 
      3 providing instructions that are as clear and \ 
     11 more detailed and relevant outputs.
     12 """
     13 prompt = f"""
     14 Summarize the text delimited by triple backticks \ 
     15 into a single sentence.
     16 ```{text}```
     17 """
---> 18 response = get_completion(prompt)
     19 print(response)

Any help appreciated.

And… now its working after closing the browser and waiting for ~ 20 minutes.

Same here also.

Authentication error is because of 2 factors as it is not getting any response from the chat GPT as the key is not recognized .
First – Modify the program by deleting. “from dotenv import load_dotenv, find_dotenv
_ = load_dotenv(find_dotenv()) # read local .env file”

Then place the OPEN_AI_KEY as you have it from platform.openai like----
openai.api_key = “sk-q5YbaIFlwn70KwD8gdy*************************SEF”
Second please make sure your key is valid if you are using the free credit

FYI: this will throw a Syntax error:
Cell In[2], line 4
openai.api_key = “sk-…”
SyntaxError: invalid character ‘“’ (U+201C)

Replace the " with ’ and it will operate as expected