Basic not working in C2W2 lab or assignment

Hello, I am working on implementing my first image augmentation model but I cannot seem to load the parameters to the model. All cells leading up to this ran fine and the outputs matched to the solutions. Please advise if this is a coding issue or software. Thank you!

The C2_W2_Lab2 Jupyter notebook for augmentation does not run either due to the same problem.

I had the same issue. However, the same notebook ran without problems in Azure Machine Learning studio, so it seems to be a Colab issue in particular. If you have access to another compute source with the right packages installed you might be able to get around it while you wait for a response. Otherwise, I am also curious as to the root cause since the notebooks prior to this one (with seemingly the same functions) all ran without issue. (I just had to modify the last cell which as-is used a Colab package to prompt the download of the history file. I instead worked within Azure ML to get the file.)

please click my name and message your notebook as an attachment.


I’m able to execute your notebook.
Please share the full stacktrace of your error.

If you’re using google colab, there’s an option to save cell outputs when exporting the notebook in ipynb format.

I faced the same problem.
I solved it by adding the following code to Colab and changing the TensorFlow version to 2.8.0.

!pip3 uninstall tensorflow
!pip3 install tensorflow==2.8.0

Please see this thread.

The problem with the version was already fixed.
Thank you for letting me know.

@Andre_Kaiser Following the thread, it seems the issue with Colab is now resolved. I confirmed I could back and correctly run the assignment which previously had the same error you posted (without any edits from when it erred).

The problem remains when I’m trying the assignment. Everything runs until the cell at the picture. Most of the code is pretty similar to C2W1, which worked fine. The only difference I see here is the error message:

RuntimeError(‘boundary mode not supported’)

I tried to install TensorFlow 2.8.0 as suggested and ran !apt install --allow-change-held-packages libcudnn8= as suggested in the link available in this thread.

Please, let me know what else I need to do to advance in this assignment.

@Jaspier Please click my name and message your notebook as an attachment.

Please fix this typo: neareast. It should be nearest

Thank you!!! my bad for not noticing the typo.