C1_W1_Assignment error

Hello! My Assignment has 0% results, but all tasks are compleated
What should I do?

1 Like

The first step is to click on one of the ‘>’ markers. This will open a text window that will tell you what the grader is unhappy about.

Please post back a screen capture image of that message.

Hopefully a mentor for this course will be able to help you.

1 Like

Hello! I try to repeat it many times, no progress…

1 Like

There are lots of threads in the forum about “grader feedback not found”.
I used the search tool and found this one:

1 Like

@Maria_Petrovskaya did you find a solution for this error? I have the same problem.

I already contact the Coursera Help Center and they told me that they can’t change the grades. I don’t want them to change the grades, just be graded.

I know I don’t have syntax error, otherwise when I try to run the code it will give errors while running, and I got all the expected results.

I refresh the environment and reboot the notebook. Resubmit the assignment and anything worked. I keep getting the 0 grade. Any tips?

Apparently your code is throwing an error when the grader runs it with the test cases the grader uses.

I’m not a mentor for that course, so I don’t know what its status is. Maybe there was an update to the grader, and your notebook is an older version that isn’t compatible.

Check on the notebook “Help” page and see when it was last updated.

1 Like

Nope, that wasn’t the error. I was using the latest version and the code was correct. Now I solved my issue and know what was the error and what not to do. The error was that I created an extra function so I wasn’t repeating code, and was calling that extra function from inside the function of the test. That function was outside the “### START CODE HERE ###” and “### END CODE HERE ###”.

1 Like

Thanks for the explanation.

It’s very important that you not add cells, or make any changes outside of the START CODE HERE blocks.

It’s a limitation of the grader.

1 Like

Hello! Where can I see the original version of the notebook? I’m trying to find
incorrect changes that I may be, but without success.

1 Like

You will need to rename your current notebook, then use the Labs Help menu to get a fresh clean copy. Then you can compare the two.

Note that if you have modified the notebook, there can be invisible changes to the metadata, which are very difficult to inspect.