C1W2 GANs for Video

Link to classroom.

I am trying to run the code from the Colab notebook attached to the assignment, but unpickling operation is not working. I understand that this is an optional task, but I would be interested in seeing the results :slight_smile: The code has not been modified; I have rerun it to ensure that nothing has been altered.

This is probably due to a package version incompatibility between the tools used in the video and the current state of the packages you installed in Colab.

I do not install these packages, and I could not find the desired requirements.txt. Therefore, this notebook will not run not only for me but also for anyone else who tries to run it until there are explicit updates to the libraries to the required version.

Sorry, I can’t test this myself, because I’m not enrolled in the course and am not a mentor for it.

Perhaps a member of the DLAI staff will help out.

I can share link to colab form lesson page if it is allowed

So, where can I find DLAI staff that can help me?

I’ll try to identify the DLAI staff for this course and contact them.

1 Like

Hi @jekagolovko, I tried to run the Colab notebook and ran into the same error you found. It looks like the problem is due to an issue loading the checkpoint file, state_normal81000.ckpt, in the wget from the first cell. The file is not a valid checkpoint file.

If you run that first cell, and then go to the left panel and click on file icon to show the files, you will see that it’s quite small for a checkpoint file - about 2000 bytes. I downloaded it and took a look, and the file actually just contains an error message from Google Drive:

Google Drive can't scan this file for viruses.
state_normal81000.ckpt (118M) is too large for Google to scan for viruses. Would you still like to download this file?

From doing a little googling, it seems that Google Drive will give this error for files over 100M.

I’ll submit a bug for DLAI staff to request a fix for this.


Any news? :eyes:
Can I find the model weights somewhere else?

I’ll check when I’m back in the office tomorrow

Update: Sorry, I don’t have access to the repo for this course.

This issue has been assigned to an engineer. I’ll see if I can get an update.

@jekagolovko, the issue has been fixed now. Give it a try!

1 Like