C4_W2_Lab_2_Intro_to_Kubernetes Failed to connect to cluster on Windows

curl.exe -d '{\"instances\": [1.0, 2.0, 5.0]}' -X POST "(minikube ip):30001/v1/models/half_plus_two:predict"
curl: (28) Failed to connect to $(minikube ip) port 30001 after 21055 ms: Timed out

I’m not able to connect to the cluster using docker as the engine. I also couldn’t spin it up
using virtualbox.

please help. I’m stuck.

Hello to the DeepLearning team,

I’m facing the same issue and can’t find a solution anaywhere. Can you help please!!???

1 Like

@Sebastien_SIME and @jnoriega , did you find a solution? I’m having the same issue right now.
I tried to get minikube ip and replace it with the curl command and I got the same error - Couldn’t connect to server

After I check out the troubleshooting for Docker driver (I’m using it), I tried to run this command minikube service tf-serving-service, it gives me more information with error, but still I don’t know to fix it.

Please see the screenshot

DeepLearning team, please help us.
Thank you in advance!

Hi @Josh_Chen, @jnoriega , @Sebastien_SIME
I apologize for the delay, the post was buried under other notifications. It seems there’s a problem with connecting to the NodePort. Please send a screenshot of your command for Virtualbox methods and its errors so we can look into it further.

Best regards,

Hi @Josh_Chen, @Sebastien_SIME @jnoriega ,
At the moment, Virtualbox’s method is more stable than Docker’s

Some command need to be changed for Window Powershell. Please check these steps:

  1. When you run minikube start --mount=True --mount-string="C:/tmp:/var/tmp" --vm-driver=virtualbox

If there’s an error like this:

This VM is having trouble accessing https://k8s.gcr.io
 To pull new external images, you may need to configure a proxy: https://minikube.sigs.k8s.io/docs/reference/networking/proxy/

You need to set your proxy before starting minikube

Run minikube ip
Then copy your IP to this command:

set NO_PROXY=localhost,,,,,,<your_minikube_ip>

Then start minikube as normal:

minikube start --mount=True --mount-string="C:/tmp:/var/tmp" --vm-driver=virtualbox

The curl command is different on Windows. The valid Json file should be be in "" and not ' like in the Ungrade_lab file. Run this curl command on Command Prompt and you should see the correct output:

curl -d "{""instances"": [1.0, 2.0, 5.0]}" -X POST http://(your_minikube_ip):30001/v1/models/half_plus_two:predict

I’ve reported this issue to the staff. Let me know if it works,

Happy Learning,