C4 W3 Colab_BERT_Loss_Model T5.dada not found


C4 W3 Colab_BERT_Loss_Model T5.dada not found.

I’m getting this error:

ModuleNotFoundError Traceback (most recent call last)
in <cell line: 24>()
22 vocab_dir = path + “/models/”))
—> 24 vocab_size = trax.data.vocab_size(
25 vocab_type = ‘sentencepiece’,
26 vocab_file = ‘sentencepiece.model’,

2 frames
/usr/local/lib/python3.10/dist-packages/trax/data/tf_inputs.py in t5_data()
51 module = None
52 try:
—> 53 import t5.data # pylint: disable=g-import-not-at-top
54 module = t5.data
55 except AttributeError as e:

ModuleNotFoundError: No module named ‘t5’.

I looked at the folder …/models/ and the file is not there:

Hi @Jorge_Mendoza,

Are you downloading the T5 module from this code cell ?

Screenshot 2023-11-30 at 9.22.59 PM

I have tried running the notebook. Everything works.

… then I realized the correct file was ‘sentencepiece.model’ (not sure why the kernel tried to find t5.data…)

Without making any changes, I ran it again and it worked!


Glad everything worked.