C4W2 Residual network model

Hi, I don’t pass the tests but I can’t see where my mistake is:

AssertionError Traceback (most recent call last)
12 assert type(A) == EagerTensor, “Use only tensorflow and keras functions”
13 assert tuple(tf.shape(A).numpy()) == (3, 2, 2, 6), “Wrong shape.”
—> 14 assert np.allclose(A.numpy(), convolutional_block_output1), “Wrong values when training=False.”
15 print(A[0])

AssertionError: Wrong values when training=False.

here’s my code:

{moderator edit - solution code removed}

I figured out! thanks

I have the same mistake and cant figure out what I’m doing wrong. Hint: Make sure you know where to use X and X_shortcut


i’m getting same error …can you please explain what was the error?

1 Like

In the shortcut path, you need to input X_shortcut rather than X.


Solved this issue. The problem regarding x and x_shortcut

I have the same code as above and still have the :

“AssertionError: Wrong values when training=False.”

error. On the shortcut path, I am using “X_shortcut”.

Not for sure what to try next. Please help!

did you get the answer

Yes, I finally figured it out. Thank you!

use X_shortcut instead of X at the end of the code

{moderator edit - solution code removed}