C4W3: Implementing Canary Releases of TensorFlow model deployments with Kubernetes and Istio

Unable to complete the assignment as ISITO is no longer supported by GKE.Please refer to link below.

Mukund Nekkanti

I also cannot finish the lab. The following is the error message.

ERROR: (gcloud.beta.container.clusters.create) The --istio-config flag is no longer supported. For more information and migration, see Migrer d'Istio sur GKE vers Anthos Service Mesh  |  Google Cloud.

Just wondering if the Istio on GKE is deprecated based on the following website: Installing Istio on GKE  |  Google Cloud. Thank you.

Thanks for reporting. I’ve notified to staff to fix this.

Hi everyone! Thank you for reporting! We’ll report this to our partners so it can be fixed asap!


Hello, I am facing the same issue and not able to proceed with my assignment. My subscription for the course ends on Nov 5th, 2022. Please help so that I don’t need to pay extra because of this issue. Thanks


Hi @chris.favila
Are there any estimated time when this issue would be resolved:

ERROR: (gcloud.beta.container.clusters.create) The `--istio-config` flag is no longer supported. For more information and migration, see https://cloud.google.com/istio/docs/istio-on-gke/migrate-to-anthos-service-mesh.

I tried this one:

# Enter your project ID
export PROJECT_ID=qwiklabs-gcp-02-c10c5eac8600

# Copy and paste the following
gcloud config set project ${PROJECT_ID}
export PROJECT_NUM=$(gcloud projects describe ${PROJECT_ID} --format='value(projectNumber)')
export CLUSTER_1=mlops
export CLUSTER_1_LOCATION=us-central1-f
export SHELL_IP=$(curl ifconfig.me) # This is required for private clusters with `master-authorized-networks` enabled.

However, ended with the following issue:

student_01_e07b94637b34@cloudshell:~ (qwiklabs-gcp-02-c10c5eac8600)$ gcloud container clusters get-credentials $CLUSTER_NAME
ERROR: (gcloud.container.clusters.get-credentials) argument NAME: Must be specified.
Usage: gcloud container clusters get-credentials NAME [optional flags]
  optional flags may be  --help | --internal-ip | --region | --zone

For detailed information on this command and its flags, run:
  gcloud container clusters get-credentials --help```

Warm regards,

Hi, I am also facing the same issue.
However, I’m able to find a workaround for installing Istio to proceed with the lab.

In Task 2, instead of creating a GKE cluster with the Istio add-on, just create a cluster without it

gcloud beta container clusters create $CLUSTER_NAME   --project=$PROJECT_ID   --cluster-version=latest   --machine-type=n1-standard-4   --num-nodes=3

Next, download the istioctl release and set it up

curl -L https://istio.io/downloadIstio | sh -

Cd into the folder (note that the version numbers may differ), and add to PATH

cd istio-1.15.3/
export PATH=$PWD/bin:$PATH

Verify that istioctl can be run and use the command to install Istio to the cluster using the demo profile, and label the default namespace with istio-injection=enabled

istioctl version
istioctl install --set profile=demo -y
kubectl label namespace default istio-injection=enabled

I am not able to get the first checkpoint to pass (Create a GKE cluster and configure sidecar injection), however the rest of the lab proceeds without issue, totalling up with 90/100 which will pass.

Definitely appreciate if the issue can be solved.
In the meantime, hope this workaround helps.


Facing same problem.

I solved it by removing the --istio-config flag. The configuration will be missing but I finished the lab normally


Hi everyone! Welcome to the community and thank you very much for sharing your workarounds! Like Fares, I also tested the lab by just removing this line from Step 2 of Task 2: --istio-config=auth=MTLS_PERMISSIVE \ . Thus, the command string will be:

gcloud beta container clusters create $CLUSTER_NAME \
  --project=$PROJECT_ID \
  --addons=Istio \
  --cluster-version=latest \
  --machine-type=n1-standard-4 \

After that, I am able to complete all tasks successfully and got 100/100. The commands also produced the expected result. The lab is able to demonstrate weighted load balancing and focused canary testing:

Kindly try on your end. If a checkpoint stays red, please wait for a minute before pressing it again. Hope these also work for you!

Hi everyone! If you haven’t completed the lab yet, the Qwiklabs team has already removed the problematic flag so you can complete the lab as is. Thank you!

Hi @chris.favila , following

gcloud beta container clusters create $CLUSTER_NAME \
  --project=$PROJECT_ID \
  --addons=Istio \
  --cluster-version=latest \
  --machine-type=n1-standard-4 \

The cluster takes very long (more than a few minutes the lab instruction adviced) and still wasn’t able to spin up. I can’t complete the course, hence the specialisation as a result … …

Hi Lim! Can you retry but change the code cell that assigns the compute zone to this before creating the clusters:

gcloud config set compute/zone us-west1-b
PROJECT_ID=$(gcloud config get-value project)

Notice us-central1-f is replaced with us-west1-b. There seems to be an issue with the us-central region and Qwiklabs Support advised (in other labs) that we try others. Hope it also works for this one!

Nonetheless, our partners are aware of this issue and are working on a fix. But hopefully, this workaround will suffice for now. Please let us know how it goes. Thank you!

*Update: I just tried the lab and it will indeed work if you change the compute zone as mentioned above. Temporarily marking this as the solution for visibility.

Hi @chris.favila , yes, your suggestion on compute zone worked. Thank you.

1 Like

Awesome! Glad it worked!

Hi @chris.favila, I changed the compute/ zone, but I cannot continue with the exercise.
I have a problem in the assessment:

Install Anthos Service Mesh
Error: Please create a Kubernetes cluster in us-west1-c zone.

Using the us-Wet1-c zone show me an error about memory.

1 Like

Hi Leopoldo! Welcome to the community and thank you for reporting! We’re currently coordinating this with our partner. Will post here asap once we get a resolution. Sorry for the inconvenience!

I am also getting the same error, tried it on us-west1-c, us-west1-b and us-central1-f but all give the same error:
ERROR: (gcloud.beta.container.clusters.create) ResponseError: code=403, message=Insufficient regional quota to satisfy request: resource "SSD_TOTAL_GB": request requires '600.0' and is short '100.0'. project has a quota of '500.0' with '500.0' available.

I am having the same error as dom1. Any help will be appreciate.

I messaged Qwiklabs support and was able to get it working in the end by using us-west1-a zone. The progress check at the end of task 2 will not work but you can do the whole lab regardless and you still pass it with 90/100.

1 Like