C4W3: Implementing Canary Releases of TensorFlow model deployments with Kubernetes and Istio

Hi! Sorry for the experience with the lab. We are still waiting for advice from our partners. If your subscription is about to expire, kindly get in touch with a Qwiklabs agent through the Help button on the lab page. The chat option is usually the fastest:

Please tell them you are taking this as part of a Coursera course and ask if they can manually mark your grade as completed. The lab has been down for several days now so I think it makes sense if they can intervene so you won’t get another billing. We’ll also coordinate this with our partners.

Please let me know how it goes. Thank you and sorry that this is taking a while!

Why not make the lab optional till the bug is fixed?

@balaji.ambresh has suggested the most logical option IMO.

I’ve contacted their support chat and didn’t get lucky.

Hi! Thank you for the update about contacting Qwiklabs. We’ll see what we can do with this info. Unfortunately, we can’t mark labs as optional in Coursera at will. We’ll escalate this issue and update this thread asap. Thanks!

1 Like

By the way, if you haven’t already, I encourage you to pause your billing till the bug is fixed. You can reach out to Coursera support using the instructions here. They should be able to direct you on how to do that. Thanks!

1 Like

Anyone is working on this? Can’t understand we have this blocker for so long time without resolving.

1 Like

Hi! Welcome to the community and I’m sorry about this lab experience. We sent a follow up and are waiting for a response about a possible workaround. Hoping it will get approved. We also informed Coursera so they can help if needed. Will update this thread again soon. Thanks!

I tried this, but that doesn’t work. Coursera refers back to Qwiklabs. Any other suggestions? Is there a backup plan if Qwiklabs doesn’t come up with a solution soon?

1 Like

I reached out to Coursera and Qwik via customer support chat. They won’t waive the lab and they’re providing no ETA for fixing this.

Hi everyone! The lab is now activated but as of this writing, you will need to change the first code cell in Task 2 to this:

gcloud config set compute/zone ${CLUSTER_ZONE}
gcloud beta container clusters create ${CLUSTER_NAME} \
    --machine-type=n1-standard-4 \
    --num-nodes=6 \
    --workload-pool=${WORKLOAD_POOL} \
    --logging=SYSTEM,WORKLOAD \
    --monitoring=SYSTEM \
    --subnetwork=default \
    --release-channel=stable \
    --labels mesh_id=${MESH_ID}

Notice that it is getting the GKE version from the stable channel instead of regular. With that, you should be able to run all the commands to demonstrate a canary deployment. I went through it and got 100/100. We asked our partners if they can revise that command while debugging the regular release. Hope it also works for you and thank you for your patience!

Indeed, works like a charm, thanks @chris.favila for the updates!

1 Like

Hello again! The lab was republished with the revised command in Task 2. We’ll consider this issue solved. Thank you!

Hi @chris.favila ,
I had problems running this lab C4W3 eventhough it has been republished. I was not able to see expected project with PROJECT_NAME-ID… rather it only displays Qwiklabs Resources under Select a project view as shown in the image below

And running the create cluster command throws following error

I have tried to logout and and login two times i.e ended lab and started again and even it does not show other project name with id attached to it.
Can you please help me, I am stuck with this lab :slight_smile:

Thank you,
Jitendra Kasaudhan

Somehow its fixed now :slight_smile: I tried again after 4 days and now I can execute cluster create commands :slight_smile:

Hi Jitendra! Sorry just saw this. Glad it’s working now! Next time, I recommend creating a new topic if a previous one is already solved. That way, more mentors can investigate the new issue. Thank you!

Good Idea @chris.favila and thanks for your response :slight_smile: :slight_smile:

1 Like