C5W4: Issues running ungraded assignments locally

has anyone tried running the ungraded assignments locally? I’ve downloaded the 2 ungraded assignments and facedf the following issues when trying to run them locally…

Name entity recognition

1. UProgress module not found: solved by removing tqdm from code
2.  no module named 'transformer' found

Question answer
1. no module named 'datasets ' 

the missing python files are also not found in the graded assignment.. so where are they? can someone who managed to run them locally please advice me? I've managed to run all the other assignments kically with no issues..

for those who faced a similar problem running the transformer ungraded assignments for week 4, here;s what I figured out:

  1. datasets module not found: pip install datasets
  2. transformers module not found: pip install transformers

obviously the transformer model come from the huggingface site. when downloading the model folder, don’t forget to download the config.json file.

I can run the Q&A notebook without issues now… but NER still have strange error at the last cell and can’t train… if anyone has a solution pls let me know. :slight_smile:

Couple of things to keep in mind for those trying to run these notebooks locally (after much error and learning, I managed to run all of these locally):

  • create a virtual environment to install packages in, since packages used may be older versions
  • check the version of packages used in online lab (!pip list) and install the same version in your environment to avoid heartache

Happy learning!