Course 1 - Week 1- Lab 1 - Grader Error: Grader feedback not found

Hi All,

I’ve been trying to submit my first assignment for a few days now - lab id is “tabhnowf”.

I’ve tried a bunch of solutions - including redoing the whole thing to ensure that I don’t change the signatures or add extra print statements. Please help me submit this - it passes all test cases but I get the error

I’m not a mentor for NLP, but this sounds to me like the “grader metadata” in your notebook is somehow corrupted. My suggestion is to get a clean copy of the notebook and then very carefully go through and just “copy/paste” over only your entered code from the “YOUR CODE HERE” blocks from your current notebook. Then try submitting again and see if that helps.

The first topic on the DLS FAQ Thread gives instructions for how to do that process. The instructions are generic and apply to NLP or MLS as well. Please have a look and give that a try and let us know if it helps or not.

Thanks for replying!

I’ve tried exactly that and it doesn’t work yet

Just to close the loop here on the public thread: Varsha and I had a private DM conversation and were able to figure out the problem. It turns out that there were some added “import” commands to bring in an sklearn package to implement the accuracy calculation. Importing additional packages is generally a mistake. If you think you need to do that for some reason, there is probably a better solution. The grader is a “black box” and we don’t know exactly what it does, but the guess is that it doesn’t just run your notebook “as is”: it must extract the “GRADED FUNCTION” cells and run them in some other context. At least that’s my theory based on the behavior the Varsha saw.

So the rule of thumb to be on the safe side is: don’t do any additional imports beyond what those done for you in the template code.