Course 1, Week 2, Lab Submission Error

I’ve completed the lab, and all 6 exercises have passed. But when I submit the assignment, I get a 0%.
Then I see what the grader output is:
There was a problem compiling the code from your notebook. Details:
name ‘MultiplyRow’ is not defined

This is the response for all 6 exercises, even though there isnt a MultiplyRow in the jupyter kernel. I don’t know how to fix this.

HI @yp011235 ,

Be sure to run your code from start every time the notebook is opened. As you have code have already passed all the unit tests, you can do a ‘run all’ from the Cell tab on the menu bar, before submitting your assignment.

@yp011235 also check out this thread

Hi @Kic ,
I tried the ‘run all’ button, saved and submitted it only to get the same error.
@Isaak_Kamau , I’ve gone through the thread, there was nothing of help.
I even tried adding something like ?forcerefresh which I saw from another thread, but that didn’t work either.
I can see that there are others that are having the same problem as I am. You can see I completed the Week 1 assignments and the Week 3 labs.

One thing that doesn’t make sense is the grader output error I’m receiving. “There was a problem compiling the code from your notebook. Details: name ‘MultiplyRow’ is not defined”. There is no MultiplyRow method in my code. I’m assuming the problem lies with the automatic grading tool you are using to grade our assignments.

Hi @yp011235 ,

MultiplyRow() is one of the functions, such as AddRows(), under Section 2.2 Functions for Elementary Operations. Could you please check, and rerun the code cell from start to the end. When you do that, you will be executing the functions under the Sections 2.2. Hopefully, the would resolve the problem.

Do you want me to rerun the cells in Systems of Linear Equations? I did, multiple times, and submitted it multiple times. All the work is there, the answers are correct, the grading system isn’t working. Cant you manually go in to look at what I submitted and give me the grade I deserve?

1 Like

Kic, the problem isn’t on my end, just look at the exercise and the grader output responses.

The first exercise is " Exercise 1: Construct matrix A and vector b"

And the output was “There was a problem compiling the code from your notebook. Details:
name ‘MultiplyRow’ is not defined”

There is no need to bring up MultiplyRow in this problem. I would post my code if it wouldn’t violate the guidelines here. But all I am doing is using np.array to create matrix A and then use np.array to create matrix B. After I run the cell and test it, I get the green response “All tests passed”.

Can you either fix this? Or at least tell me why ‘MultiplyRow’ needs to be defined in an exercise that’s unrelated to it?

Hi @yp011235 ,

I ran your code under Codlab, and I couldn’t find anything from the code that is causing the error output “MultiplyRow is not defined”.

If you have downloaded the assignment to work on your local machine, it is possible that some of the metadata that is specific to be used by the autograder has been corrupted, causing it to output ‘Can’t compile the code …’ message.

I suggest you refresh your workspace and take out a clean copy of the assignment and rewrite the code. That way, we can be sure that nothing is upsetting the autograder. Please follow the instruction here to get a clean copy of your lab.

It is a better practice to do your assignments under the Coursera platform and then download the files to your local machine for safe keeping and reference, removing any platform related issues.

I completed the lab on Corseras platform. I finished the course. Can you please just give me the 100% grade?

@yp011235 what’s your score in this lab after trying @Kic solution?

Hi @yp011235 ,

The grading is given by the autograder. If your submission report is not giving you 100% marks, then please post the submission report for us to find out what the problem might be.

Thank you,
Starting the lab over from the beginning worked.