Course 5, Exercise 1, Week 1 Grading issue

I’m having issue with the auto grader. I have completed both exercise 1 and exercise two. The sample test within the assignment indicate my code is compiling and executing correctly.

When I go to submit it to the autograder, I’m getting a weird error “Cell #7. Can’t compile the student’s code. Error: AttributeError(”‘NoneType’ object has no attribute ‘shape’")". I’ve tried resetting kernal, deleting and redownloading the files, and other small tips I’ve seen recommended.

I don’t understand where the error is coming from. Any advice?

Try resetting the kernel, and clear all the output.
Then “run all” the cells in the notebook.
Then inspect every output cell carefully for any error messages.

Note also that passing the unit tests in the notebook does not prove your code is 100% perfect.

I believe the issue to be cells further down in the assignment causing the compiling error. I had been submitting a partially completed assignment to check if I had completed the first exercise correctly, but there were cells further in the assignment that had the same error message as the one popping up. Only by completing all of the exercises, was I able to submit my assignment.

The assignment system could be made more robust if un-attempted exercises didn’t cause a compiling error. It is reassuring to see that an exercise is completed correctly before proceeding, as the later exercises tend to build on or even call previous exercises as functions.