Different tfds version on grader?

Continuing the discussion from Error: TypeError("init() missing 2 required positional arguments: 'op' and 'message'",):

Stuck for 2 weeks on this, help anyone ?

I haven’t found a work-around for this, and I am not sure how to increase the grader verbosity to debug it in more detail

Hi! :wave:

Can you make sure that all tfds.load calls have data_dir parameter passed?

I was finally able to get this to work by specifying the data_dir parameter while using tfds.load()

Hi Yuri

I indicated that I had tried this unsuccessfully, tried these two:

splits, info = tfds.load(“cats_vs_dogs:4..”, split=splitnames, with_info=True, data_dir=f"{getcwd()}/data",


splits, info = tfds.load(“cats_vs_dogs:4..”, split=splitnames, with_info=True, data_dir=‘data’,


Note both do work with the web version, it’s the grader that refuses it, probably because it is not using the same version

Full ipynb attached fyi



thank you for sharing the notebook; please, refrain from sharing the notebooks publicly in the future, use DMs for this

Sorry, I was using email, thinking I was talking to support

How can we get support/grader admin confirming or explaining what’s going on there ?


Hi @Olivier_van_de_Wiel. Sorry, I’ve missed your message. Were you able to resolve the issue?