GANS Course 1 Week 4A Assignment

My code works fine and I get the message: Congratulations! If you’ve gotten here, it’s working. Please let this train until you’re happy with how the generated numbers look, and then go on to the exploration!
But, when submitting I get this error during compilations.
The Cell #UNQ_C4. Can’t compile the student’s code. Error: RuntimeError(“Expected object of scalar type Float but got scalar type Long for sequence element 1 in sequence argument at position #1 ‘tensors’”,)
Lokking at earlier discussions I saw people suggesting the compiler was running a previous version and I tried to change it earlier versions yet nothing helped. Any suggestions?

Hi Prakhar!
I hope you are doing well.
Do refer to this thread - 305904 and check if it helps you (It points to one more thread too, do check it out).
If you still face difficulties/issues after doing that, feel free to post your issues.

Yes, it’s the same error message that was caused by the issue described here.

It looks like there are several ways in which the grader causes problems by running an older version of pytorch.