GCP RESOURCE_EXHAUSTED, can't deploy model

Hi!

I am struggling with ungraded lab [C4_W1_Optional_Lab_1_XGBoost_CAIP]

I have successfully trained the model and obtained predictions, but when trying to deploy the model using this command:

!gcloud ai-platform versions create $VERSION_NAME \
--model=$MODEL_NAME \
--framework='XGBOOST' \
--runtime-version=2.5 \
--origin=$MODEL_BUCKET \
--python-version=3.7 \
--project=$GCP_PROJECT \
--region=us-central1

I get the following error:

Using endpoint [https://us-central1-ml.googleapis.com/]
ERROR: (gcloud.ai-platform.versions.create) HttpError accessing <https://us-central1-ml.googleapis.com/v1/projects/rock-objective-405110/models/baby_weight/versions?alt=json>: response: <{'vary': 'Origin, X-Origin, Referer', 'content-type': 'application/json; charset=UTF-8', 'content-encoding': 'gzip', 'date': 'Tue, 14 Nov 2023 14:43:45 GMT', 'server': 'ESF', 'cache-control': 'private', 'x-xss-protection': '0', 'x-frame-options': 'SAMEORIGIN', 'x-content-type-options': 'nosniff', 'transfer-encoding': 'chunked', 'status': 429}>, content <{
  "error": {
    "code": 429,
    "message": "The requested number of n1-standard-2 exceeds the quota limit. Current usage/limit: 0/0, Requested: 8.",
    "status": "RESOURCE_EXHAUSTED"
  }
}
>
This may be due to network connectivity issues. Please check your network settings, and the status of the service you are trying to reach.

I’ve googled all the possible solutions but the problem persists.

I am using a fresh google account with a free trial $300.

1 Like

Did you check your network connectivity?

Danil, are you trying to run on your local Jupyter??

Please follow this link to increase your quota.

1 Like

I am running on GCP in my personal account which I had created just yesterday for this particular excersise.

Network connection is stable.

1 Like

I have found this solution before posting the question here, but it does not work for me. I just do not have the ‘n1-standard-2’ resource in my quotas list.

1 Like